Download

Issues with blueprint inheritance

I have the following inheritance:

ACharacter -> BaseCharacter (c++) -> BaseCharacterBP -> Goblin

Basically BaseCharacter has code in c++ to handle movement, BaseCharacterBP contains all the gameplay logic except for movement, Goblin only adds a specific mesh to BaseCharacterBP.

BaseCharacterBP has the property Pawn:Use Controller Rotation Yaw **not **set. Goblin should have everything the same as BaseCharacterBP and only change the mesh, however every time I launch UE it is back to “default settings” (ie flag set and doesn’t match parent class).

I change these settings to match BaseCharacterBP, hit compile, save, close UE. When I open back UE, the Pawn:Use Controller Rotation Yaw flag is set. Is there some issue extending Blueprints?

Regards,
Nuno Afonso

The only issue I’ve ever seen is that enums seem to get screwed up if you set one in the defaults at different points of the chain. I solved that problem by resetting it in the construction script. It sucks, but it works.

Here’s a video showing it happening:
https://youtube.com/watch?v=Qb2hs3fL_g4

I’ll provide a bug report soon.

Regards,
Nuno Afonso

That’s very similar to my struct issue, except it happened the second I compiled the blueprint. I had a struct of different types of pickups. I made intermediate blueprints that were each type before making the actual pickups. The actual pickups kept reverting back to misc. Finally I set the type in the construction script of the intermediates and it solved problem in game. However it still shows up as Misc in the defaults.