Issues getting audio spatialisation working with a large grid of AmbientSounds

I have a grid (9 by 12) of AmbientSounds, & I want the volume of each one to increase/decrease as the player gets closer/further away. The project is intended as an FPS-style in VR for audio engineers, so spatialisation of the sound is important.
Each AmbientSound is the same length and they all need to play synchronously with all the others.

Issue #1 - Sounds restart their playback if player leaves & re-enters sphere on influence.
Solution - Enable “Virtualise When Silent”. This is noted here just in case there’s a better way to do this…

Issue #2 - If Attenuation Override is enabled, Virtualise When Silent does nothing.
If I turn on Attenuation Override and force all the AmbientSounds to have a fairly small and evenly-spaced attenuation falloff, then playback restarts every time the player moves inside the next sphere of the influence and out of the last one.

Issue #3 - If Attenuation Override is disabled & a custom Attenuation Settings is used (with similar settings as the override), then none of the sound sources play… at all.
Been playing around with changing the auto-activation of the AmbientSounds and/or forcing them to begin playback at load via the Level Blueprint, maybe I broke something there? I’ve played around extensively turning them all back on again.

Issue #4 - Attenuation Override is disabled & NO custom Attentuation Settings used, some of the sounds play but Spatialisation doesn’t work.
Not sure how many are playing… it only sounds like one file but when they’re all playing in perfect synchronicity it’s hard to tell the difference.

Issue #5 - Made a Level Blueprint to emulate volume-controlling attenuation settings… but does nothing, as far as I can see. Successfully calculates volume and AFAIK applies properly… BUT

  • If Attenuation Override is on, spatialisation works but all Sounds start/restart as player moves into/out of their sphere, instead of all playing at once.

  • If Attenuation Override is off and no custom settings are applied, all sounds play at once but at equal volume, and spatialisation doesn’t work.

  • If Attenuation Override is off and custom settings are applied, no sound plays at all.

Any ideas?

I think I’ve solved my issue by…

  1. Assigning an Attenuation Settings to the sounds;

  2. Disabling the “Enable Volume Attenuation” checkbox;

  3. Hacking a dirty location-based volume-falloff into the Level Blueprint as per the first screenshot in the post above.