Download

Issues cloning imported FBX meshes

Hi Unrealers. First at all I would say that my english is very bad but I will try to express myself as I can.

Im trying to make a personal project for infoarchitecture, making some props in 3dsmax and export in FBX format for import that mesh in Unreal Engine 4.
For the first test I make a modular piece for a wall of “U-glass” in max, exported in FBX and so far all it’s fine.
My problem comes when I try to duplicate (with alt key, with copy&paste, etc…) that mesh. When I do this, in “Scene Outliner” panel I can see the mesh cloned but only the Gizmo appears in the scene of the mesh. When I look the details of the cloned mesh he haven’t any Static Mesh applied. When I try to click the arrow that allow to “use selected asset from the browser” nothing happens.

After trying the same with random meshes imported I put in the scene the default SM_chair of UE4 and I can clone it with “Alt” key with no problem, so that I take the original chair, exported from content browser to FBX and reimported as an external asset and putted in the scene and…the same problem! I can’t duplicate/copypaste/clone that mesh.

All this induces me to think that the problem is when I import the FBX File.
Can anyone help me with this? :confused:

P.S:Here a couple of Screenshots in order to show easily that I happens if my way to express is too incomprensible
paso1.jpgpaso2.jpg7df8bc34e0908c54d1395247f7177cf911d471f2.jpegpaso4.jpg

So this should have to do with how you’re assigning the shader. You apply the shader to the placed mesh in the level and then duplicating it, which grabs the shader applied to the static mesh from the asset browser.
Assigning a shader in a placed mesh is like an override, so if you have 20 red cube, and one of them to be green, you can select that placed mesh and assign a green material without affecting the others. As well if you change your mind and want the red cube to be purple, the green one won’t be affected. The key is to assign the material in the asset, not in the placed mesh, unless you want to change the default behavior.

It could be a bug, but I have not encountered that particular bug, and I’ve been doing a lot of importing / exporting… possibly try another version of FBX (2006/2008), which Unreal will complain about but sometimes sheds light on what’s wrong…

Hi Vulkaj,

I’m very curious as to what is going on here. I do have some questions for you though.

What version of 3ds Max are you using?
If you are using 2014/2015 3dsMax you need to make sure when you export FBX you select the 2013 fbx option. 2014 won’t supported until our 4.2 build releasing in the coming weeks.

Are you on the latest build of the engine 4.1.1? If not, what build are you currently working off of?

Have you tried using this assets in more than just this project and been able to replicate the issue?

If want you can always upload your asset here and I’d be glad to see if I could replicate the issue and/or if it’s just something with the FBX export settings being off.

Thanks!

Tim

Hi again.

@DrCrosby
Thanks by the help and fast answering , but I assign material to the asset. Anything go worse with my project or maybe I touched something that broke the scene. I try in another project and can import and clone with no problem. :confused:

@Tim Hobson
I’m using 3dsmax 2014 and exporting with 2013 fbx option, the build of engine I use is 4.1.1 and how I said before I tried to import the same assets in another project (in a blank project, in Stylized demo, etc…) and I have no problem importing FBX. Have to say that when Im working with this scene Ue4 Crashes often times (My computer isn’t a great machine) and probably one of the crashes corrupted or something the scene :confused:
Another thing that I try is drag the same asset from the content browser again and again in the scene and with this way I can have any clones of my asset, this is a clumsy solution but it works for advance the project.

https://mega.co.nz/#!IBAlQayb!pThC-5uVY5DoFxvuh8Gs94Bi53xgd30gf82GNxcUBzI
This is one of the assets that I can’t clone (well, I can’t duplicate any asset that I import). A simple “U” Piece without materials but that works and can be cloned in other projects.

On the other hand I upload all the project folder too if some kind soul can download it (1.31 Gb :confused: ) to help me to find the origin of my problem (Probably some dumb think that I did in whatever moment)
https://mega.co.nz/#!BJ5WXTwI!xCk8OEGgivGby4V0XBnXyo7-S9NVXiIhzGR6pg2cSvg

Thanks a lot and for my part, I still searching and testing with my low knowledge of this Great Engine :smiley: If a I have some news, I post it here

Hi Vulkaj,

Wow…so after digging around with this for a bit and scratching my head trying to figure out what was going on I’ve managed to solve your problem. :smiley: Good news is you’re project is fine! Bad news is you’ll have to rename the folder and not use the ‘’ or ‘]’ around the folder name.

I will say getting the look on some of the peoples faces here in tech support was priceless when they were curious how it was doing this.

I’m not even sure if this is a bug or just something that shouldn’t be done when naming folders. I’ll have to look into that part though. But for future reference don’t use any symbols around your folder names. Just Alpha-numeric naming.

Glad this worked out!

Thanks!

Tim

Greetings Tim! Lord of the code, Master of Unreal Engineland! My saviour!

That was a great news! and as I say, the origin of my problem it’s

It’s a bad habit my use of “” & “]” for mark important folders, to find it easily ever at the top of the list but after this case I believe that the best I can do is change it for a underscore (less “beautiful” but with equal efficiency).

Thank you very much! and sorry about the headache!