Issue with Water Body River not conforming to my landscape - UE5.1

As you can see from these images, my river is not conforming to the terrain.

I’ve tried adjusting the amount the river affects the landscape, turning off “affects landscape”.

And some other things but anything to help would be great.

I’m using a 8kmx8km landscape from a 4k Gaea heightmap.

The grass is a landscape grass type.

This also happens on the Water Body Ocean where my it SOMETIMES leaves a gap before reaching the cliffs at the edge of my island.

I was having the same problem. Go to your waterbody material, check UseFixedWaterDepth and check the true box. Also, the water depth for that water body will now be controlled by the “Fixed Water Depth” value under the water/advanced tab. All of my water bodies have the same material so it worked for my rivers, lakes and oceans. Don’t know why it resolved the problem.

3 Likes

Thanks for your reply OdoSedo.

It hasn’t fixed the issue for me. In fact setting “UseFixedWaterDepth” to true and changing the “FixedWaterDepth” value does nothing.

Sorry it didn’t work for you. The water system seems to be very hit and miss at this time.

1 Like

Going to look into FluidNinja as an alternative

Hey there @Tazwin! Welcome to the community! Generally the water makes the terrain conform to it instead of the other way around. So let’s check and make sure everything is set up properly first and then we can go into a trick or two that let you manually sculpt whatever you need here.

So first let’s verify your landscape currently has edit layers enabled.

The reason I ask, is because this controls how the landscape conforms to the river. Same with oceans. You still need “Affect’s landscape” ticked on so let that be.

Next, if it is actually affecting the landscape, but has really jagged edges, changing between width and angle here can often help.
image

Let me know how that’s going right about now, then we’ll go a bit deeper.

1 Like

Hi @SupportiveEntity,

So here’s Enable Edit Layers on my landscape:

And here are my river splines (I plan and changing it to one spline as some point, I now know I can add spline points):

FYI: The two river actors by the lake are an Alpha Blend, the rest are set to Min for the Blend mode.

Let me know if you want me to provide anything else.

Thanks

Huh, usually the width correction tends to clear up the discrepancies with the sides of rivers. How is the resolution of your landscape? It looks like it should be enough to avoid the disruption. Are curve depth settings effecting the river’s at all?

My landscape is 8kmx8km from a 4k heightmap.

These are my Curve settings for all my rivers if that’s what you are wanting.

image

Hrm, with similar settings I’m failing to get that kind of tearing. Is the river on the 4k map itself flat? If not it could be causing the discrepancy. Could you hide the landscape’s map layer and see if the flat it shows conforms correctly?

I know it’s been a while since the last post, but what helped me was checking both FixedWaterDepth and FixedZOffset and setting them to true.

2 Likes

Thank you Ill give it a try.

I am Facing an issue as well, the effect on the landscape of the river has a weird offset(the little S valley) on the left, instead of being under the river

Is there meant to be a river on the left?

1 Like

the river is where it should be, but the land deformation underneath the river is on the left instead of being under the river.

I have no idea sorry buddy. Unreal is a big pain for these sorts of things though I can understand. Although that “Water Clear height” is quite large maybe try adjusting that.

Hey there @EmmadIlyas! So I’ve been tracking some similar water issues that primarily occur with maps that have external heightmaps of sufficient size. Are you using a height map? What’s the scales/distance of your map? Judging by your water clear height it must be quite large.

No, it is not an external Hieghtmap, Created this with Landscape blueprint brushes.

Now that’s interesting! What about the other questions? Size/scale are the apparent core of this issue usually, but I’ve only seen it like yours with external height maps.

Hi, I have a similar issue here. The River tool won’t deform the terrain and looks wierd. I have a external tiled depth map. Is there a solution to this problem? Thanks in advance.