Issue with the World Outliner

The world outliner is stuck as a window in the taskbar seperate from the main editor, it’s not visible in the level editor itself. I try to open it but it jumps back to the level editor instead. I have enabled the world outliner in the window options. I simply can’t make it appear in the level editor together with the details panel.

1 Like

post a screenshot please

Did you ever figure this out???

I am relatively new to unreal and was just undocking some windows and ran into this same issue. (Specifically with the world outliner, not the others as far as i can tell.) You can see by the attached screen shot that my World Outliner shows up in the list of window options in my windows taskbar, but clicking on it just puts focus back onto the editor, not re-opening the outliner as expected.

image

I have also tried deleting the “Saved” folder from the project folder and still no success. Also, for what it’s worth, When I initially tried to undock the world outliner, I was trying to drop it onto a 4k monitor which was NOT the main monitor that i had the editor up and running in. This problem persists into making a new map as well.

WORKAROUND FOUND - If you right click on the world outliner in your task bar, then “MAXIMIZE” it with the RMB context/options, that seemed to put the window at full screen, at which point i was able to move it and dock it in the desired position again. Hope this helps.

One final note i found i guess (to the devs here), is that i’m seeing this behavior more when i’m using the tab itself (the one you’d click and drag to dock into a different portion of the editor, not the window it creates once you drop it onto your screen somwhere.) Now in my case, I have a 4k monitor that is aligned with the bottom of my other monitors, and i tried to drop it into the area above the top of where my 1080p monitor aligns with the 4k monitor. (So drag from top of the 1080p monitor, then go UP to the corner of your 4k once you slide it far enough onto the screen to see it.) At this point, it looks like it is snapping it up and off the visible space of the 4k screen. (Which is ahy maximizing it likely brings it back.) Weird thing tho, and not sure if this is just because of where i have my taskbar, but my 4k monitor is on the right of 3 monitors, my taskbar is on the left, and maximizing from the taskbar on monitor 1 makes it show on same monitor as taskbar. not a huge deal, but maybe more info for you guys.