Download

Issue with the Editor or PEBCAK?

Reaching out for a bit of help. I ran into something that has had me scratching my head for almost 48hrs now. It’s a weird journey bare with me.

So I’m new to the dev kit but not new to modding in general, and I wanted to make a mod or two for personal use on my server. I started out with the basic tutorials of making new items and custom tables ect. Anyway my mod only changes base values. Stack size, Weight, Durability for armor and weapons. I was about to start modding the beacons ItemSets when I discovered Remap Engrams/Items/SupplyCrates (as none of the tutorials bothered to mention this bit) I figured I don’t need custom tables for these edits with the ability to remap, after all I don’t plan to distribute this mod. Up to this point everything worked perfectly, both in editor and on my server. Well this is where things got weird. After pointing all of the items back from the custom tables to the vanilla, the vanilla Fabricator just… stopped working. The Smithy (or Anvil rather) works as intended and it was the same process for both tables. However with the Fabricator the items appear in the inventory but are unable to be “Craft” only “Repair”. Oops, I must have made a mistake somewhere right? Well after hours of comparing children to the base files (making sure not to miss the important check boxes like CanCraft, CanRepair and the StorageBox & ItemToBuild references), re-parenting classes, clearing and redoing all references, deleting and rebuilding my child of Primal_GameData_BP, and finally reverting all edits I made to all Fab items, the Fabricator still wouldn’t allow me to craft anything within its inventory. So as a last resort I completely erased the editor from my hard drive and reinstalled thinking I must have changed or corrupt a core file. Once reinstalled I launched into the fresh and squeaky clean editor for the 2nd time, hit play, addexp, giveengrams, spawned materials and a fab, and yet still I cannot craft a single item within the inventory. WTH is going on? At this point I have no issue starting over from scratch but I can’t even do that if the core files are not working as intended.

TL:DR~ At some point in the process I think I managed to break the vanilla Fabricator and even reinstalling the devkit doesn’t seem to have fixed the issue. Vanilla items show up in a vanilla Fabricator without the “Craft” option only “Repair” on a clean install of the devkit.

I guess my question is this, ignoring all of the above, how can I ensure a clean and functioning install of the devkit? I use the Epic Games Launcher not Steam.