Download

Issue with Parameter Texture Object node in 4.22

Hello guys,

I have an issue, when I try to use Parameter Texture Object node in Unreal 4.22 from material editor.
When I use the node it breaks the volumetric lightmap.

For your convenience I am providing you a link to a video with example.
Video - https://youtu.be/RrmiMWCRsWo

Thanks,
Kind Regards.

Interesting. It looks to me like a manifestation of Unreal Engine Issues and Bug Tracker (UE-72575), which also affects the texture object node (not just object parameter) and normal lightmaps as well.

I have the same problem.
Materials which utilize TextureObjects (Parameter/Non-Parameter) do not contribute to Lightmass.
It’s an issue only in 4.22

I have the same problem
since updated to Engine version 4.22

This issue has been logged by our teams - thanks for calling it out!

So I noticed that this issue was marked as a duplicate and supposedly fixed. This issue is *not *fixed in 4.22.1; in fact there seems to be no change at all. Would you be able to re-open the issue?

Amoser forwarded me to this thread. I too use texture objects on pretty much all my materials (world aligned materials). And I too had the issue where suddenly my scene’s were a lot darker. I posted the before and after image in this thread. And here is an updated screenshot where you can now see the scene in 4.22.1 using a different material, and indeed the scene lights up nicely again. So big thanks to Amoser for posting this and to TihomirVFX for figuring it out and I’m glad to see it’s been logged by the Epic staff. Hopefully a hotfix for this can be released as I’m sure a great deal of people will be affected by this?

Just a quick update - this has been re-opened and our teams are investigating!

https://github.com/EpicGames/UnrealEngine/commit/a711880d7344effa7edf8fa9841ccb5575c6d40b Seems to be fixed.

You’re link doesn’t seem to work. Does this mean that this fix will be included in the next patch update?

You need to be signed on github. I guess it should be on next major patch. 4.23.

Hmm, ok, I guess this could be another few months then until this is fixed? Seems like a pretty big issue that would perhaps warrant a hotfix, since anyone using world aligned materials won’t be able to bake their scenes and I would assume there’s a lot of people that work this way? Or am I creating my materials in a bad way? Since you need texture objects for world aligned materials to work?

Are there any updates on this issue? I’ve tried the github patch and it doesn’t seem to work for me. Does this issue have a Unreal Engine issues number yet (as UE-72575 was closed as duplicate)?

The link that Kalle_H dropped in is the new fix as of 5/6. Does it not do anything for you?

Not fixed here
I just spent the whole weekend trying to fix what caused this issue, after having two 10+hours bakings wasted…and I just found out this topic (btw searching for some information on this forum is a complete mess)
So no, it’s still not fixed in 4.22.3, so I’m rolling back to 4.21

Still happening in 4.22.3. :frowning:

Luckily we are only early-development on project. Rolling back is not an option because 4.22 fixed the particle system memory crashing bug.

Didn’t do anything no, lightmap bakes are still darker than they should be.
I think I found the duplicate for this issue. Is it: Unreal Engine Issues and Bug Tracker (UE-73373)
Is that the duplicate of Unreal Engine Issues and Bug Tracker (UE-72575)

Both still marked as broken in 4.23

4.23 fixes my problem with texture objects on dynamic materials.

Wait, so does this commit fix the issue, or no? If so, can it be cherry-picked to backport it to 4.22.3?

[Edit] I tried back-porting it to 4.22.3 using git cherry-pick and it seems to work.

From the 4.23 release notes:

This is the commit that fixed the bug for me in 4.22, so I guess it was incorporated into 4.23? Has anyone tried it?