Download

Issue with face smoothing?

I have exported a model from Blender to UE4 and something is not quite right… if you look at the page on the left, it has an issue around the edge, the page looks embossed or curved around the edges.
Any idea what this might be?
I tried setting the faces to both smooth and flat, and changed the SMoothing optiopn in the fbx exporter but I don’t see it making a difference…
The page on the left is actually a skeletal mesh, and animated to turn (it’s finished turning in the screenshot). You can see the non animated mesh on the right hand side (and that is a different exported fbx). The static mesh doesn’t show this problem.

42e3fe05b70c300a26d31a152808b29a39b46114.jpeg

Hi Re-Games,

I think your face normals may not be straight. Can you show us a screenshot of them from your modelling app? :slight_smile:

Please watch this short video by Warren Marshall as reference: https://www.youtube.com/watch?v=MWsipxVFwj8

I hope I could point you in the right direction. Happy modelling and let us know how it goes.

Sure… thanks for the quick response. The normals look straight to me… will watch that vid now…
f2f228bdfec96af3b4177b1a4a600b29516ea4a9.png

ahh yes, if you project the average normals like Warren shows his you will see the exact same thing he explains is happening on the outer most tiles of your mesh :slight_smile:

see if the front face normals are actually disconnected from the edge you the “paper”, THEN and only then they will really be straight :smiley:

That makes some sense, BUT, I am actually seeing this issue on BOTH sides of the page, and one side is entirely 2d.

Here is the front side (which is 2d):
b7ea534c9bab6bf888c570d173a7ab3089f09121.png

And in the game:
0300ee397908c33806ff68eae0369ea2af7b1667.jpeg

I don’t know how to operate blender but try to make a “hard edge” between:

  1. the front faces and the tiny side faces

  2. the back faces and the tiny side faces

==> then the interpolation of the normals should stop

alternatively hit me up on Skype and we try to fix it one on one :slight_smile:

The Edge Split modifier is already in use here.
I don’t have Skype installed here but thank’s for the offer.
I put in another loop and pushed it very close to the edge, this more or less covers it up

^^ yup, sweeping the effect under the rug also works xD

what are your import/export settings? anything on smoothing groups?

I think Chosker maybe on to something here too! Please make sure either your export (blender) and/or your import (UE4) settings don’t accidentally override the normals and tangents by recalculating them using some undesirable default settings. :smiley: