Download

Issue with AI Movement

Hi there,

I’m trying to get some simple navigation based movement, so I’ve created a landscape with some obstacles on it (tree trunks). Then I’ve created the nav mesh, but when I add an AI char it’s movement is really horrible (it’s jittering from left to right and even walks in circles or getting stuck - just see video) although it basically just should move to some Waypoints until it reaches the gate.

I’ve been browsing through the forum for quite a while and everything, I’ve found made the problem just worse (things like orient rotation to movement, set the dynamic obstacle of the capsule component to true and set the area class to navarea_default, increase movement speed, RVOAvoidance on and off, can affect navigation on and off, every possible or impossible cause). Also, I’m not really sure if the nav mesh is correctly set up (my feeling says no due to some strange polygonal issues (see screenshot)

Total NavMesh (The dots in the green area are tiny billboards, which actually serve as waypoints)
https://s28.postimg.org/46weuwpm1/Nav_Mesh.png

“holes” in the nav mesh which make me believe the mesh is corrupt
https://s28.postimg.org/iem3jk2ax/Nav_Mesh_Possible_Bugs.png

BehaviourTree Setup (appears to be working if I use the move directly node, however the AI then crashes into obstacles, which is actually not worse than it is right now haha)
https://s28.postimg.org/jecef9hgp/BTree.png

Video of the ai behaviour

Do you have any idea what causes all the trouble and how I could fix it?

Kind Regards and thank you,

Markus

PS: photo upload in the forum still doesn’t work. First it complains about a file size larger than 5 MB, then, once the file size was below those 5 MB, it just says <p>Database Error</p>

Is this a single nav mesh for the whole level? Have you tried scaling navmesh’s height?

Hey,

thanks for your reply. Yes I have. After a whole day of debugging I have maybe found the reason: The sword and shield of the rat appear to affecting the navmesh. Have to test it first, however.

The sword and shield was blocking the path ._.