Download

Issue when using Paint tool on Terrain in Unreal Engine 4

Hi all,
I was wondering if anyone could help me with an issue that I have been having recently. So in Unreal Engine 4 I have started to create my terrain, however when I use the Paint tool to try to either sculpt or paint a texture on to it, I get a black rectangle instead that fills a section of the terrain instead. I have read online that numerous amounts of people have had this issue, and after researching about it and trying to fix it, I still can’t fix it. Does anyone know how to fix this, and why does it do this?

Any help on this is greatly appreciated. Thank you :slight_smile:

I ran into this a long time ago when I tried to cut a hole in my landscape. From what I’ve seen the bug still hasn’t been resolved. Do you by any chance have a hole in your landscape? It may be the same issue.

Hi JonF,
What do you mean by a hole in the landscape?

Like cutting out a hole in order to put a cave or something in there. That’s when I ran into this issue.

What have you already tried to fix it? :slight_smile:

-paint over the entire terrain with one layer and then try to paint with another one
-which version do you use?
-could you post a picture of your material?

JonF: I don’t think I tried to do anything like that at all. It’s just when try to paint the texture on the terrain itself, I get this result, and when I try to sculpt the terrain to build a hill or something.

fighter5347: The picture that I posted at the start of this thread is the result of when I covered the entire terrain with a grass texture, and then I tried to paint the dirt texture where that black rectangle area is at. Do you mean which version of Unreal Engine 4? If you mean that then I use version 4.7.3, which I just updated to last night, and version 4.7.2 was giving me the same issue before as well.

Do you mean from inside the Material editor itself, or do you mean from the Terrain editor under the Paint menu, or do you mean when I select a section of the terrain itself?

Is it a possibility that I could use cubes if I set the X, Y, and Z coordinated as a flat plane? I don’t know if I would be able to sculpt or paint on those surfaces like with a Terrain plane itself.

-from inside the material :slight_smile:
-you can do it with cubes, but you wont be abel to paint on them, sculpt them and they wont have a good performance

fighter5347: Here is the image of inside the Material I’m using. If it’s not close enough let me know, I can go back and zoom in it on some more.

Hey so I managed to figure out of what was causing the black rectangles to appear. I had to break the link from my normal maps off, and then it would show the the different textures being painted. However I now have a second issue that I don’t know how to solve. So even though I’m able to paint a different texture on to my terrain now, how do paint it in smaller sections? When I use a smaller brush size, it will always paint one huge section of the terrain now. Is there a way to fix that issue?

However it seems I’m able to sculpt at different brush sizes, so it seems that works now.

Another question I have now is how do I apply Normal maps to my terrain textures without having them cause my terrain textures to disappear when I link them? Do I have to use something else besides a LayerBlend?

Here’s an image of what the paint tool does now even with a smaller brush size.
a30c59557871208390992bbe795bb521ec429f57.jpeg

  1. paint with one layer over the entire terrain - after that you can paint with the others
  2. Hmm, normally it should work that way (e.g Texturing a Landscape in UE4 (Unreal Engine 4) - YouTube) but check the names of the layers if they are correct :slight_smile:

Hi I need your help with the issue your having, can you tell me what you mean you had to break the link from normal maps off?

I think he just disconnected the normal maps nodes :slight_smile:

Hi, im having the same issues and I can’t move forward. I have read everything. When you say paint with one layer over the entire terrain, would that be on a black newly created landscape? Ive tried everything

Thanks, im new to this and im self teaching, when you say he disconnected normal maps nodes, how did he do that?

Do a right click on the normal map link - disconnect :slight_smile:

Are the normal maps set to actually be normal maps? (both in the texture asset settings and in your material).
And it might be possible that there’s some issue with what kind of blending your landscape layer blend is doing (alpha/weight/height).
I’m pretty tired so this might not be so easy to read -_-