Download

Issue packaging (Resolved)

In addition you might also need

The win 10 SDK - 10.0.19041.0
https://developer.microsoft.com/en-us/windows/downloads/windows-10-sdk/

4 Likes

Thank you, that did resolve the issue for me.

1 Like

I don’t know why, but now it works for me too. I had installed this before, but it didn’t work then … maybe I was missing the combination with that and the SDK. Thanks a lot!

I ran into a similar error and after following the suggested solution and installing .NET 3.1 I was able to to begin a build. However it would fail and give me the error
“UATHelper: Packaging (Windows): ERROR: Could not find NetFxSDK install dir; this will prevent SwarmInterface from installing. Install a version of .NET Framework SDK at 4.6.0 or higher”.
This led me to this post which pointed me in the right direction.

If you’re still having issues after installing .NET 3.1 open up the Visual Studio Installer and click “Modify” from there open the “Individual Components” tab at the top and search for “.NET Framework 4.8 SDK” and install it. This immediately worked for me.

Working in 5.0.0 Early Access 2 and I am unable to package for Windows even after having all the correct SDK and dotnet installed and in the right places. You can see from the dropdown that the sdk is installed. Strangely it shows a different version on the device than is installed in editor. I have no idea what else to try. I can create windows builds just fine from 4.26 so its definitely just UE5 related.

2 Likes

Thank you, this helped me with packaging a project that I’ve brought vom UE4.26.2 to UE5 and couldn’t package because of the ambiguous message “The SDK for Windows is not installed properly, which is needed to generate data. Check the SDK section of the Launch On menu in the main toolbar to update SDK.”

All WIndows 11 Users who are facing this problem must have the 2019 visual studio app installed with all c++ plugins and you must install the windows 10 sdk drivers here Windows 10 SDK - Windows app development. once the sdk drivers are installed, open unreal, click platforms, then click your pc to update sdk and restart. after that your projects should successfully package into your desired folder. This is what worked for me on windows 11

@OALANDFOX: Have you moved your project folder to the root of your harddrive? See here: https://www.youtube.com/watch?v=L6PSdDX4oYI

Did you find any fix for this?
I’m having exactly the same problem!

I’ve been developing with UE5 ER2 for a few months and was able to build for Windows fine. Today I had to compile some 4.26 plugins for UE5 with Visual Studio and now I’m getting this same can’t find the Win64 Binaries error and I can’t build any more.

I currently have this exact error with UE5 ER2. A day ago it was packaging fine, but I must have done something in MSVS I’m guessing.

As annoying as it may seem I found the only fix was to completely uninstall/reinstall UE5 from a clean slate. This only seems like a temporary fix though as the same issue appears again after a few days. Must be some internal bug where someone hasnt added the correct pathnames at a certain junction.

1 Like

Do you have any solution for Mac? When I click update device the SDK is installed successfully, but when it is restarted, UE tells that SDK is not installed properly and I cant Cook the Mac. Thanks

Hi guys, this issues seem to be caused by a number of reasons, I tried all of the solutions mentioned above with no luck. What did the trick was installing the SDK .NET

image

I hope that might help someone

Thank you so much man.