Download

Issue mostly resolved, please ignore first post

I recently decided to switch from Unity to Unreal Engine, given that Unreal seems to have a much better track record when it comes to well-made games. I expected a high-end popular engine like UE4 to run with little to no trouble on a high-end computer with 4k resolution and an excellent graphics card. However, upon starting this engine, while well documented it seems like I’ve encountered more errors and technical problems in a week than I ever did while using Unity.

First of all, the resolution of the viewport is abysmal, like Unity I would expect the viewport to simply adjust itself according to my monitor’s native resolution, but Unreal for some reason seems to display it’s viewport in what I would call 720p regardless of any kind of changes I make in the settings, and these settings are hidden behind a bunch of unnecessary windows and tabs. It seems that the engine itself has a mental breakdown if you change any graphical quality settings. It consistently crashes on me if I make the smallest changes in these settings. I can’t even add a bloody cone to a blank scene because I keep getting lighting errors which I can’t even fix using the build option, for which I also get .dll errors relating to cryptic software that doesn’t seem to be enabled along with the installation of the program.

I respect the amazing work that has been done with this engine in the past, but for some reason it just doesn’t seem to be very user-friendly. I have not come across any official documentation relating to the problems I have encountered, and the possible solutions I have explored are absurdly out of the way solutions that should be made simpler.

As I said, I respect the work created with this engine, and I don’t know if I’m missing something, but this engine has been a consistent pain to use in the few days I have utilized it.

I have been using it on a 4K screen since 2014 and I have no idea what you’re talking about…
Might be some problems related to specifics of your hardware parts.

My machine works perfectly fine with other engines and software though. I really don’t know what’s the problem. I even reinstalled UE4 just in case something went wrong but I still encountered the same errors.

The engine works perfectly fine for me (2k monitor and not so recent pc build).

It might be something with my computer, I’m not sure. Like I said, I don’t hate the engine, I’m just frustrated that I’ve encountered so many errors.

Can you please try this fix for the resolution problem?

https://answers.unrealengine.com/que…t-scaling.html

i tryed both unity and unreal engine, and imho unreal is so much better than Unity, I think if you can fix this problems and you learn to work with UE you will fall in love with it :slight_smile:

if the fix of the resolution is working we can just try to see the crashlog file for understand why the engine are crashing.

That worked perfectly, thank you so much! All the options I explored never even mentioned that solution.
As for the error message, it occurs when I try to build lighting. I get the following error:

C:/WINDOWS/SYSTEM32/wbemcomn.dll is either not designed to run on windows or it contains an error. Error status 0x0000006.

I’m not sure if this is due to a corrupted install or not.

I’m glad that you resolved the resolution problem, wbemcomn.dll is a Windows DLL, i want to be clear that this is NOT a common unreal engine error,

you have the last version of Windows 10 installed on your system? Are you sure your system has not been corrupted previously from a malware? Seem’s more a Windows problem when trying to access that DLL (corrupted maybe?)

I just managed to sort out the light building problem by unticking the box that says Allow static lighting under Project settings - Rendering - Lighting.

i think in this way you are forced to use Dynamic Lighting. You probably have disabled static lighting, but i think is better if you try to fix the DLL problem instead disabling static lighting :wink:

I realize that now, the error seems to be related to SwarmAgent.exe

Can you please upload the crash log? It will be easy to understand the crash reason with the crash log file.

Well I no longer get any crash logs since you showed me the solution for the resolution problem. Those crashes I mentioned only occurred when I attempted to change engine scalability settings and material quality level. The only error I still get is the one I mentioned, I receive no crash log from it, I just get the error message: C:/WINDOWS/SYSTEM32/wbemcomn.dll is either not designed to run on windows or it contains an error. Error status 0x0000006.

Pardon me, I understand you meant the swarm agent log. I get this error message everytime I try to build the lighting:

10:11:00 PM: [Interface:OpenJob] Error: The type initializer for ‘System.Management.ManagementPath’ threw an exception.

I’m sorry but I don’t really know how you can fix it, but i’m more or less sure that you have some problem with the OS, or atleast there is some corrupted file/s on your system because this is the first time I heard about this problem. Let’s see if someone else can help you, otherwise I can suggest you to trying restore that wbemcomn.dll, try a chkdsk or a clean re-install of Windows 10 if no other solutions is available, again to me seem’s more a Windows problem and NOT an UE4 problem.

The wbemcomn.dll is part of Windows, but there are reports of some malware able to disguise with that name to be in your system. One possible error is that your antivirus is not liking swarmagent, so in this case you can use another antivirus or add swarmagent to the list of exceptions. The best course of action would be run a system check which will verify all windows components and see if everything matches the source. For a system check follow these steps:

  • open a command prompt window as administrator
  • type at the prompt: sfc /scannow
  • hit ENTER and wait for the tool to finish the diagnostic

Let us know your findings.

I did as you suggested and found that I got a message at 55% of the system scan saying that “Windows Resource Protection could not perform the requested operations”.
However, I have found that by enabling Force No Precomputed Lighting in the World Settings, I no longer have to build lighting. I know this limits me to dynamic lighting, but is it entirely necessary to build static lighting? I’ve never been a fan of baked lighting myself so enabling this option would not be such a terrible thing for me.

Run “CHKDSK C: /r” and after the reboot scan run again sfc /scannow

if the error persist try running: “ICACLS C:\Windows\winsxs” and launch again sfc /scannow

if the problem persist I can suggest to run the repair utility from the Windows ISO or backup your data and reinstall Windows.

Regards.

Nothing’s working guys, and I am NOT reinstalling windows. I think I will just go with a project based around dynamic light. I’m not sure why I’m experiencing these errors specifically with this engine, I’ve used baked lighting in other game engines with no trouble at all.

EDIT: I do appreciate all your patience and help from you guys, I’m sorry if I flew a little off the handle with my opinion of your engine. I actually quite like it.

I have never experienced your issue and I use Unreal Engine since version 4.8… the issue is not with the Engine, but the environment you are experiencing the issue.