Download

Issue: Blueprint works fine (but only most recently placed one).

So, I’ve been having some fun making a Door blueprint with as much interaction as I can come up with for the player (gradual open/close with mouse wheel, lock/unlock, knocking, busting the door down with a kick, etc, etc.)

I’m having this issue where the blueprint works as intended, but if I have more than one copy of it in my levels, only the most recently placed copy of it actually works. The rest no longer (seem to) accept any input from the player. I hadn’t noticed this before, but the blueprint by default was set to “Auto Receive Input: Disabled”. So initially, the whole thing didn’t work. I set this to “Player 0”, and now I’m in the situation I’m in currently, where nothing seems to work on older placed copies of the blueprint and I have no idea what is causing it.

http://ss.myth.ro/t/zh27i.png

http://ss.myth.ro/t/DJ24S.png

http://ss.myth.ro/t/c796b.png

I can post parts of the blueprint itself if needed (if it’s not just an obvious thing I’ve missed, or something).

On another note, just tried door physics. Seems to be working correctly! :stuck_out_tongue:

If it were me, I wouldn’t use Auto Receive Input at all. I would leave that parameter at default.

If I was appraoching this, I would create the functionality for all those actions you described to the door, then I would trigger these different functions in the door blueprint by firing them off from the player.

Example idea:

  • player presses the “kick the sh** out of the door button”
  • player BP fires an event or function in the door BP
  • door BP does what it’s supposed to

Prety simply, and you can do this by communicating between player and door either by a) casting or b) using a BP interface

Either way is easy to setup and solved the problem. Let me know if that makes sense…