[ISSUE] Black Interiors with Outdoor Lighting Only?

Hey everyone,

I have an issue deploying the “Mobile Temple” game to my Samsung Galaxy S4 GT-I9505 (UK) mobile phone. I have successfully deployed and played the “Tappy Chicken” game so I know my computer can output to my phone easily.

When I deploy the “Mobile Temple” game though I get this issue below:

I’m wondering if it’s not loading the content such as textures that it requires. As speculation could it be because I deployed “Tappy Chicken” first and it isn’t loading the content over onto my phone for some reason? Should I completely remove all UE4 content from my phone and try re-deploying?

I am using the NVPack by the way too.

Thanks in advanced,
Christopher Rose, BSc (Hons)

[issue solved]

I solved my issue, it was because I was using the wrong texture compression method for my device. I found out what my device supported using the app below:

Hardware Info App:

This allowed me to see the supported texture formats as shown here:

And now it looks like this!

Where do you change the Texture compression size ?

Where do you change the Texture compression size ? Because I get the exact same issue.

Find out which compression technique your phone is compatible with first then the option is in the drop down list when you select to deploy


Galaxy S3 here. The first time I built with PVRTC and got the same black/white screen. After reading here I changed the texture compression to ETC1(I saw it in the app you gave) but since then I’m unable to start the game.
I’m not sure if everything gets built correctly because it doesn’t matter what settings I use it’s always the same size on the phone 67.67mb.

Tappy Bird works fine.


Have you tried completely un-installing the game from your phone and removing the game folder and it’s contents from your device, then attempt again to deploy to your phone? If not try the same process again but instead package the game for your phone and try it that way and let us know what happens.



I tried but it still doesn’t work.
Guess I’ll have to wait for official support or just migrate to newer phone for tests.

The only thing working now is TappyBird. From Swing Ninja I can start only the menu and even there what should be black building is pure white.

Btw on your screenshots and the ones from a friend of mine(with S4 like you) there’s no directional shadowmap visible. You only see the GI lightmaps but no light/shadow from the sun. I guess the next couple of updates will sort things out.

Thanks for the ideas :slight_smile:


To enable the distance-field shadows from the sunlight, modify AndroidProperties.h and make SupportsDistanceFieldShadows() return “true” instead of “false”. And yes, this has been fixed in the UE4 code base. :slight_smile: