Download

Is there any way to access the files in the content folder via blueprint ?

Why can’t you update to 4.5?

I didn’t try it with so many images, this is not so fun to drag them one by one :\

This project is done and this is the only thing to add, and when moving to newer versions there are always bugs and i don’t have time to check the whole game again, i got only 1 day or 2 to finish it.

I am also an advocate of BP having as much power as possible :slight_smile:

And yes I can make a node for this, one sec!

Rama

Dear Sahkan and Everyone,

**Two New Nodes

Get Object Path & Load Object From Asset Path!**

I have created the node you requested, and also its compliment, so that you can get the asset path of any object from the world during runtime!

In my test case I specifically loaded a Texture2D from asset path :slight_smile:

I gave you the same code I use in C++ with my in-game editor that saves and loads levels for my game to compressed binary files :slight_smile:

More info here and download link here!

50636d2c4796a81ed34c35ff97a6269fe5aaa1c0.jpeg

OMG Thank you so much man !!! :smiley:
I’m gonna try it right now !

I’v just tried it in 4.2, and it gave me these messages :
701465b7964224591fe69d8abdc9ef6101e29793.jpeg
Clicked “Yes”.
Starting to compile with a small loading window for about one second and then :
2.JPG
Clicking “Yes”.
Editor starts loading and then :


Afterward the project started and all seems to be good, there Victory plugin is checked as installed but there are no new nodes between the blueprints nodes.

Is the new code contains elements that are not in the 4.2 version of the engine ? :\

I compiled the BP library for 4.5 :slight_smile:

You are still on 4.2 ?

I can recommend upgrading at least to 4.3

If you do 4.3 I can get you a 4.3 version

Rama

I think i will be able to make the array in 4.5 and move the uasset files to the 4.2 project version, i need to try.

I’v just tried to install the new plugin on a new blank 4.5 project, and this is what happened ( also happaned in the previews version before this one ) :

1.JPG
Clicked “Yes”
And then it shows this for 1 second or so :


And then it gives me this :
528d442b5cf080396918c383fb3d8a8e15cd159e.jpeg
I press ok and nothing happens next.

This is how i’v installed the plugin :
9e12ce563a8ea5564080822391a144ddbcf49708.jpeg

DLL files are there no doubt :

Any idea what is wrong with my build ?

I am not sure what your issue is, because I am using 4.5 for the plugin too and it works great!

The Test I Did

I just did the following test:

  1. copied the entire folder that comes as my Victory BP Plugin over to a BP-only 4.5 project

  2. opened the project

  3. added some of my BP nodes to the level blueprint

and it all works great!

I am on 4.5 full release, and again it is a BP-only project I am testing with, though I’ve also tested with full C++ projects as well.

Are you using The Github verson of 4.5 ?

My tests are working out great with full release 4.5 so I dont know what to tell you, also no one else has reported any issues with 4.5 version of my plugin so far.

I am not sure what’s going on with your 4.5 build!

I’d be happy to help if I could reproduce the issue but its not happening for me, in either C++ or BP-only 4.5 full release :slight_smile:

Rama

I’v built it from the source code, maybe i should build it again, so weird, i will update here after some trials. till then, Thank you very much, you’v been a great help ! :slight_smile:
Oh and if you can make a 4.3 or 4.4 build so i can try it there, that would be great :slight_smile:

no no!

if you are building from source code that explains the issue!
**
Github and full release versions of UE4 stopped being binary compatible back in 4.4**

So you cant ever treat them as the same

I dont see what the issue is though

if you have source code just use my full Victory BP C++ source code that I give you with every build and compile it yourself!

Every version of my plugin that I’ve ever released contains the full source code!

  1. Just start a new C++ project using your github version, then copy over my entire download, and compile.

  2. Once its done, you can copy the .dlls over from your new c++ project to your main project which may not be C++ based.

  3. Now this compiled version of my plugin will be binary compatible with your custom github engine version :slight_smile:

And make sure you are using my latest version, dated today

Rama

NNNiiiiiiiiiccceeeeee !!! Gonna try it right now !:smiley:

Awesome this is working !
This is what i did if anyone want to know .
Created a new c++ blank project in 4.5, compile it ( takes some time ).
Then, add the plugins directory with the victory plug in it ( Like you would normally ).
And now, when the Editor said it need to recompile, it recompiles and not failing like before, and then this is all good and working.
So i guess only c++ projects can recompile stuff.

Pretty awesome!

How do you save that video as textures. Is there a program that does this or did you do it frame by frame?

VirtualDub ( Open source ) .
Export => image sequence. ( There are a lot of programs that can do that ).
I am doing the same now on longer video which is 1500 frames and it takes all day just to import and save the images and also it is gonna take about extra 1.5gb, i will update about the performance of it once it is done .

Ok after made that array of 1520 frames and start running it. it ran it but after 2 seconds it started to make little freezes in the game ( Probably because of the memory been full ) So i guess this is only good for some really small videos like the one i have in my video :expressionless:

I wonder if you can scale the resolution of the textures down to help with that issue.

Also, perhaps there is a way you can forcibly remove textures from memory that have already been viewed? I don’t know about the lifecycle of such data in the memory, but perhaps it is piling up or there is something else going on.

Could this do more of the array building task that was enquired about at first?

Such as Get Object Path of one texture, find all the other textures in the same path as that object (ie, the Get Object Path without the object itself), so they can be put in an array…

The “Load Object from asset path” is always failing on me : / tips?

I’m able to get an image in the same way but not a “Primary data asset” ? Is that a limitation
?