Is there a way to use physical animation without having to use the PhysicalAnimationComponent?

The workflow for using it requires you to create it and then call its SetSkeletalMeshComponent() and ApplyPhysicalAnimationProfileBelow() methods. I know it’s supposed to be nice that they allow you to control physical animation through code at runtime, but I don’t need runtime capabilities. Are there any in-editor options to just activate it without the component?
For me the ideal scenario is in the physics asset editor, I could just enable it. That way the character mesh is more portable (has physical animation anywhere it’s used). I was also looking for a way to possibly activate the physical animation profile through the character’s post-process animation BP, but still don’t know a way.

Hi Brian, I’ve been able to use the PHAT editor to do this, without using a Rigid Bodies node in the AnimBP or setting up anything in the CharacterBP (like a Physical Animation Component). As far I remember, it just involved making sure your Skeletal Mesh is using the right PHAT, and setting the bodies in PHAT to ‘Simulate’ (I think remember to leave one at ‘Default’ as root, unless you’d like to fully ragdoll)


One thing that comes up with doing it this quick way though, I’m really struggling to get the Physics Animation Profile to work in this way, directly applied in PHAT, though (may be possible but I’m still figuring it out). It SEEMS to be possible in PHAT, but I’m not seeing any behavior change when I plug in huge numbers.

The Physics Animation Profile DOES work if you go through the full set up and apply it in CharacterBP or AnimBP as below:

I’m combining two PHATs - the first for physics (using the Rigid Body override in the AnimGraph) and the second (nominated in BP and applied in the AnimGraph) for just for animation.

As for Post Process Anim BP, I haven’t touched this yet so I can’t really say.


Yes, it can be done without a physical animation component, and without a Post Process Anim BP. The first Physics Asset is set to ‘Default’ - which the animations (of the imported anims or Control Rig anims) drive.

It uses the main Anim BP, with a Rigid Body node that nominates an override Physics Asset. This second Physics Asset is set to ‘Simulate’ - which the physics (of the rigid bodies in the Physics Asset) drive.

One thing to note is, select the Rigid Body in your Anim BP above, and in the settings a) Override the Physics asset and b) set the Simulation space to ‘World space’ instead of ‘Component space’ as here:

This is a useful starting point. I think there is a more sophisticated way though, that will give more control. My investigations continue :slight_smile:

1 Like