Is there a way to stop a blueprint object from colliding with itself?

I have a coin object in my game, all the actual object does is destroy itself when touched but it needs to simulate physics as it is spawned with velocity. The problem is I spawn multiple coins at the same time and they’re colliding against each other and going buck wild! They’re like going all over the place and I’m like omg how can I stop this!

If I turn collision off completely the coins fall through the ground and the player doesn’t have chance to pick them up. Is there a way to tell the object to collide with everything but itself and maybe the player?

In component mode select your object and under collision set collision preset to ‘Custom…’ From there you can specifiy exactly what you do and don’t want your coins to collide with.

You did it! thank you!

Or In The Coins BP, Set In Collison Object Type: Physics Body, it Shall Collide With The Ground But Not Itself, Also Might Have To Use Custom To Only Enable Or Block World Static And Overlap All Else, And Might Have To Set Collison Enabled: Collison Enabled (Query And Physics), BRU!