Is there a way to set collision for 2D Top Down to the sprite's collision instead of the collision capsule?

I’m having an issue where my Character is colliding with the wall and then clipping or snapping down. I’m not exactly sure what’s causing it, but I have an example as to what it’s doing: Problem With Movement/Collision - YouTube
It appears to only happen in the top corners and not along the sides or the bottom corners.
I was following this tutorial: Paper 2D #5 - Top Down Character Full Process - Unreal Engine 4 - YouTube
I eventually did the whole project again, but still the same results. My code is the exact same, it’s just my character and tiles are not. The character has its own sprite collisions and the tiles are basic square tiles. I have my Collision Radius set to 20 by 20, and the tiles are 32 by 32.

I haven’t figured a work around this either, there is unfortunately so little to go off on for top down 2Ds in Unreal. :confused:

I decided to flip the table. (Literally)
I just flipped the tile map and character to be set to xy rather than xz where the character was set to Y constraint. I set the character to Z constraint and I guess it works that way. Even with gravity turned off, I suppose it was still a little finicky.

Just wanted to say that I was having this problem and was using the same tutorial to build a top down game, and after several days of trying to fix it, I found this and it worked! Thank you so much!