Is there a way to resize widgets[Sprites]?

Is there a way to resize widgets? I know we can toggle them with Game mode, but when you have a lot clustered close together, it gets very hard to see what’s what.

Also, could we have a toggle in the Blueprint Components view?


Hi Walternate,

Are you referring to sprites? There can only be one widget on the screen at a time, for whichever actor is selected. Sprites are the visual references to lights, audio, Player Start, etc.


You cannot currently scale the size of sprites, but you can choose which types of sprites you see in the Viewport. Under Show > Sprites, you can select the types you want to see and the ones you do not.

Hope that helps!

Ben Halliday

Thanks Ben, that helps (though a nice size setting would be great some day;)).

There is no Show menu in the Blueprint Component view though, and no apparent way to hide/show objects in the Components list (i.e. eyeball in Scene Outliner). It’s a bit hard to see underlying geometry…


Awesome! Thanks :slight_smile:

Thanks for bringing that to our attention! I’ll enter a feature request in our system for a hide/show option in Blueprint Components and a sprite size adjuster in the Viewport.

Aha! That’s the business!

You may want to sneak that into to the Blueprint Component editor ToDo list :slight_smile:

Thanks Ben!

Upon further testing, it looks like you CAN resize sprites in the Viewport on an individual basis. Select the sprite you want to adjust, and in the Details panel go to the Rendering section. Editor Sprite Scale is what you’re looking for! You can drag the slider left and right or enter a numeric value to adjust the size of the sprite in the Viewport.

Hope that helps!

To set it for all objects:

  • Viewport Options (chevron in the top left of the viewport) →
  • Advanced Settings
  • Level Editor
  • Viewports
  • Look and Feel
  • Billboard Scale

I found that setting Billboard Scale to 0.2 was a reasonable workaround.

Although ideally, a new option to set the Billboards to a constant scale regardless of the depth, would be nice. Exactly like Unity’s unchecking 3D Gizmos

Thanks to Ben Halliday’s answer for pointing me in the direction to find this global answer.

Is there any chance we could ever get a fix for this in the Blueprint editor? Those sprites are completely blocking my view. And I can’t find any editor sprite scale in the properties for my component (a spotlight component).

In 4.18 I am not seeing any such ‘Billboard scale’. Has it moved? Can anyone tell me where?