Is there a way to override or desaturate the Diffuse Boost in Lightmass ?

Hi everyone,

I’m getting started with lightmass calculation and I found this problem, the light bouncing back of surfaces is bringing too much of the diffuse saturation with it, although I like the effect and the amount of light being bounced I would like to have some control over it, similar to what we can do with a vrayoverride mtl.

So is there a way to add a script to the shader or some other setting that will override the diffuse saturation in the lightmass?

Here is an example of what I mean.

The walls are white, so as you can see the red/yellow from the wooden floor is being reflected on the walls and ceiling, this is a good thing, but I would very much like to reduce this effect to say 10-20% in saturation (keeping the brightness).

Thank you very much!

One quick workaround you can do is to just build the environment with a white floor, and then pop the wood material back on after the build is finished.

Otherwise you can fiddle with the diffuse boost settings but I’m not sure if it’ll affect the brightness or not.

I havn’t figured out the best way but the GI from the floor can be controlled with the indirect lighting intensity of the directional light and the number of indirect light bounces in world settings. What I’ve done is balance a directional light with a skylight, can also shine a spotlight on some diffusers or use color grading in a post process volume.

You can control GI color per material. Just make the floor emit some gray tone and you’ll get rid of the saturated bounces. Take a look: Utility Expressions | Unreal Engine Documentation

I will try this, i think this going to solve my exactly problem than op had
my floor is contributing too much gi information to roof

thanks for share this info!

This method is cumbersome. Biggest disadvantage is every time Lightmass needs to be re-built you have to change the material to white and then again change back to final material.

You can change the Diffuse Boost settings for the material which is causing the effect. Setting can be found under “Lightmass Settings” of Material. This will not have any effect on the overall GI of the scene.

Thanks everyone for your help on this.
at the end I did use the Lightmass replace, it did exactly what I need it.
Tried GI replace and also removed the color bleed so two option that worked.
Thank you again.