Is there a way to make timelines/matinees ignore time dilation?

I’m trying to achieve an effect where when the player unpauses the game, the global time dilation interpolates smoothly from nearly 0 to 1. The problem is that global time dilation also affects timelines and matinees. This makes the curve controlling the time dilation itself slow down!

I could individually set the custom time dilation of every other actor in the game but that’s kind of insane. Is there any way to make the global time dilation not apply to a single actor?

I think your question is how to get delta time which is unaffected by time dilation, as time dilation is scaling delta time.

Well I don’t strictly need the real world delta time myself, just for the timed curves in question to compensate for it.

Can you set global time dilation then just set the custom time dilation on your matinee or playrate of your timeline to an inverse value?

I don’t know of a way to make that work for matinees but I’ll give it a try for timelines. Hopefully the imprecision won’t make things get too out of sync.

I’ve not actually seen the results but i could get a Set Custom Time Dilation node from a reference to the Matinee actor in the level. I think Matinee’s also have a playrate you can set. Lots of holes in these approaches to Matinee though :confused:

Once again this is all just sort of conjecture since i don’t think the actual functionality you want is there. :confused:

Setting the custom time dilation to an inverse worked without any hassle. I’ll accept this as a workaround if you submit it as an answer!

I am surprised yet delighted that it worked for you!

u could try something similar to this:

note: in your case it would probably be a division instead multiply, i hope u get the logic here :slight_smile:

I dont know if you still need this, but in 4.17 I stumbled upon a new node in timelines where you can specify that they should ignore global time dilation

hmm interesting, what’s the name?

There is a checkbox when editing a timeline as well as bool property when you access the timeline variable. It’s called exactly “ignore global time dilation”

didn’t ever see it. ill check it up next time in run the editor. thanks :stuck_out_tongue: