Is there a fix for the Camera Spinning the wrong way in the sequencer?

UE-22228 the bug where the camera spins the wrong way in the sequencer doesn’t seem to be fixed. I have a U shaped camera rail and i’m trying to make the camera follow the inside of the curve. The camera spins the wrong way to hit the next rotation point. Is there a fix for this? Can I have an option to choose which way the camera rotates (counter-clockwise or clockwise) to reach it’s next rotation point, please?

1 Like

Wait, i’m dumb. You can change the euler angles in the graph :smiley:

1 Like

Right clicking in the transform field >properties and set to use Quaternion Rotation did the trick for me!
Or maybe thats what you meant :slight_smile:


Yes! Thank you for this

Where exactly is Transform Field Properties?

Oh, found it. You need to right click on the root Transform area of the timeline (above your location and rotation keys) and then go to properties and you’ll see the option for Quaternion Rotation).


Oh, so in my situation, switching to Quaternion made all of the rotations seem linear and mechanical even though my curves were not linear. They all had an abrupt stop to them rather than a smooth transition. So, I actually figured out that what was happening was my pitch value was going above 360 into a range around 700 to 800+. So what I did was subtract 360 from those values (744 - 360 = 384) and manually set a new pitch value for all of my frames, and this actually removed the extra spin on my camera. Now granted, I had to do this for every single key frame AFTER the rotation glitch which in my case was 23 keys which was tedious, but it meant that I didn’t have to use Quaternion rotations which kept all of my rotations looking smooth. So just be aware that switching to Quarternion rotations for the entire sequence isn’t the easy fix that it seems to be as it will drastically change the result of your rotations.

1 Like

Four and a half years later, your answer has helped me :slight_smile: Many thanks :slight_smile: