Is there a bug with the restart game node?

I am trying to restart the level by pressing a button Actor in game. I have done this in the past but for some reason I cant get it to work anymore.

First Ii tried to use the restart game node but it wont connect to game mode??
or anything else apart from casting to game base mode,

And I also tried to get current level name and open level But my project freezes up and crashes If I try that.

GetGameMode returns a GameModeBase class.

I still have this problem.
Currently I am pressing a button actor in the level, I want it to restart level
If I use the either the open level node or the execute console command with the “RestartLevel” the game freezes up in vr and my VR hands freeze while a hourglass icon spins for about 15 seconds, Then it loads the level. ( NOT GOOD! )

But I cant find a single way to get the restart game node to work either.
This is so frustrating as it should be very simple to do, Not sure why Its acting like this.
I Pulled this off in the past and it was an instant level reload.

I have this running of a tick event for the button movement and once a condition is met its calls the restart