Download

Is the Remap Resource Components working?

Maybe I don’t understand how this array works.

If I remap a resource from the original, to a new resource, what does that actually do? I thought it would mean any Base Crafting Resource Requirements that were the original would instead consume the new? This doesn’t work.

I have tried remapping the engram from old to new, and new to old, as well as the blueprint from old to new and new to old. Nothing seems to allow the new resource from being used in place of the original. ie: if there are 10 items that have the original resource in their crafting recipe, none of them are substituting the new resource instead.

Any help?

After some conversations, it seems this doesn’t work, or isn’t intended to work for actually remapping resources.

This is really needed!

In the same way you can “Remap Engrams” with 186, we need to “Remap Resources” (or Classes!). Why would you want to recreate every class / blueprint in the game if you change a resource?! And then re-do that with every release that makes the slightest change?! What if you changed a crafting box, like the Smithy? You would have to copy every single blueprint that references the Smithy to your Mod, to change 1 class reference, and cook all of that too? That’s madness.

Any comments from the Devs on how to handle this?

I think this work only for Resource Harvesting Components but not all of them. It worked for Seed/Wood/Stone but not for DinoDeath