Is the learning platform broken?

I’m trying to access the learning platform for the first time (Learn How to Use Unreal Engine - A Powerful Real-Time 3D Creation Platform - Unreal Engine) but it is completely unreachable!!

I try to access ANY course, e.g.: Your First Hour in Unreal Engine 5 | Course, but when I hit the “START COURSE” I get redirected to this dead-end: Register as it takes me to this horrific site: Register. I’ve been trying to access it for the past 2 hours, been trying to contact support but they can’t give me any info.

Is it a general problem with the entire learning platform atm, or just an issue with my account?

This is what I see when I try to access ANY content:

I’ve been trying to access it for hours -.-

Same problem here. Tried Firefox and Chrome. Are you logging in with an Epic Games account or Gmail/FB etc?

I tried both Firefox and Safari and logged via my epic games account.

Seems to be working now.

Nopes… not for me. Maybe if you already signed up before. I’m still reaching that annoying registration page that is a complete dead end. “Please try again in a few minutes” -.-

Yeah, I signed signed up over a year ago.

1 Like

Same here. I have been trying to sign up since yesterday… :disappointed:

Same here, tried different accounts and mails nothing works…

Hey folks!

I just wanted to quickly chime in here and let you know that we’re looking into the issue with being unable to access courses or register for the platform. I will keep you posted!



@SkyeEden Thank you! Please keep us posted.

I was able to login. Thanks!

1 Like

Thank you! I was finally able to get passed that screen! :raised_hands:

1 Like

I managed to log in as well. Thank you!

1 Like

I’m still not able to logging. Every course I try keeps refreshing or redirecting infinitely.

It’s not working for me either. I haven’t been able to get through the infinite loading page since two months ago, the rest of the site other than learning works for me though.

Yes this is still happening for me. I got some support help and it was sent to developers but haven’t heard back in a week.

Turn off “3rd party cookie blocking” to fix not being able to login to online learning