Is PrimaryAssetLabel broken?

This is the best forum section I could find for my question.
I have been trying for hours now to separate my pak file into chunks on disk. I followed all available posts here and did everything I can think of. PrimaryAssetLabel simply does not work. I have to enable the experimental chunk ID feature in the editor settings and assign chunk IDs per hand to each asset, then I get separate chunks.

I would just love to hear from others. If it is broken then I don’t need to waste any more time on this. Does anybody have positive or negative experience with that BP type? Thanks

So in my experience you apparently need to add the primaryassetlabel files into the Project Settings -> Asset Manager -> Primary Asset Types to Scan or it basically ignores them completely.
It also seems to ignore the primaryassetlabel’s rules settings, so I ended up duplicating the Chunk ID, priority, etc, into that section as well.

Now that I’ve done this, the assets do seem to be going into their chunks as expected, but additionally they’re being duplicated into other chunks if there is a referenced asset that needs it elsewhere in another chunk! :open_mouth:

I wouldn’t say it’s “broken” per-se, but it is definitely poorly documented and perhaps unfinished…

Yes I had some contact with Epic and it turns out when you create a BP with rightclick and then select the PrimaryAssetLabel from the “All Classes” list you get something that does NOT work.
You have to select the one from Miscellaneous from the long list.
Another way of making sure you get the right version is to remember that the right version has a RED icon whereas the version with a blue label (normal BP) will not work.
As for your remark I think you have to jiggle the priority value. When two rules apply to the same asset the one with the higher priority number prevails

Wait, what? OMG! So my muddling in the Primary Asset Types to Scan section is not actually correct then? Such in Unreal I guess.
To reiterate, you don’t create a Blueprint Class of the type PrimaryAssetLabel, but a Data Asset of the subclass PrimaryAssetLabel.

Sadly, I’m still getting massive duplicate assets (exploding my build from 6.44 Gb to a whopping 11 GB). Le Sigh.

This is how you actually create the correct one.

I assume after that it’s alot of analyzing the pack file and adjusting priorities and creating more of these assets to fine tune your distribution

Yeah, that’s where I’m stuck. Seems the cooker is really keen on keeping stuff in pak 0. I made a “catch all” asset in the root content directory:


Which (to my understanding) should shove anything not already covered by a higher-level PrimaryAssetLabel asset into pak 888, yet nothing ends up there (the file doesn’t exist).

This is just beyond inconceivable. The most basic test epicly fails…

1 Like

I haven’t really used it so I can’t help much. Maybe try the other methods like Explicit assets and such. I hope I don’t run into those problems when I finally get to pack my project. I have to keep the pak files under 2Gb

No worries! Until better documentation comes around the only thing we can do is experiment. To that end, I spent a few days cooking and packaging several different iterations of settings, and the best I can say is “if you click ‘Apply recursively’, you’re going to end up with duplicate assets”

It’s fine I suppose, users have extra space on their drives for that, right? /sarc

2 Likes

From the screenshots it appears your in UE4? I’ve used assetlabels that work correctly and pak into files based on the pack chunk ID in UE4 but I’ve indeed ran into an issue where this no longer works in UE5 preview 1 forward. Currently able to repo the issue in UE5.1 so I’m not sure if something has been changed there in the cook command of UAT that its not respecting the asset manager?

1 Like

Any solution? Still not working in ue 5.1