Is it possible to use Unreal Engine 5 on an old Mac?

Recently I have been trying to use UE5 on my mac. my mac is a Retina 5K, 27-inch, Late 2015 running macOS Monterey (Version 12.6.6). I can install UE5 Completely normally on my mac, but when i open UE5 it says that i need to download Xcode from the app store. Apple’s Xcode needs the latest software update for macs, the only problem is my mac (being bought in 2015) cannot update any higher than what it currently is, because the newer version are not supported. I am wondering if there is a for be to download Xcode or a way around this where i can use Unreal Engine 5.

**Thanks! **

1 Like

Hey there @whenisgamora! Welcome to the community! So this mostly depends on what version of Xcode is the latest your Mac can install. I believe the lowest you can go is Monterey 1 version lower than yours so you may be clear, and it requires Xcode 14.1 or better.

The following software versions are compatible with the current version of Unreal Engine:

Hello @SupportiveEntity Thank you for replying! Currently, on the app store, it says “requires macOS 12.0 or later.” I guess the version offered is version 14.3.1, But I don’t know how to get the previous version of xcode.


Once you get the correct version for your OS version, if the engine can’t find it, you can select it using some of the methods shown in this thread:

Either doing it that way or the command way:

sudo xcode-select -s (Location of Xcode)

1 Like

@iSinSlayer Thank you for the help, but after signing in, I got this error message:

It Happens on any one of the downloads and I don’t know what to do.

xcodereleases points to apple’s website, unfortunately they will let you download older xcode versions only if you are an apple developer…
I guess the only way for you to get an older version of xcode is to enroll to the apple developer program, for a fee of course.

If selecting the version the way I indicated didn’t help out, another user had to fully reinstall before it worked out:

Upon going to the enroll page i still receive the same error message. And i want to avoid paying money for things anyway.