Is it Possible to login to Unreal Engine behind a proxy that requires HTTP login?

I work for a large fortune 500 company that has a fairly restrictive proxy system. In order to get online you need to authenticate via a webpage, every time you close the browser the session expires (and sometimes mid session) and you need to login again.

Currently when I try to login to Unreal Engine it tells me it can’t login and asks if I am connected to the Internet (which I am). Is there any way to get around this? I am currently evaluating Unreal as a solution for some applications we are looking to develop. If we can’t login then needless to say it is DOA.

Hi mr_pink :slight_smile:

There is an easy option that would take an hour to set-up. Unfortunately it means downloading the Unreal Engine Four source files from github, (after setting up a free account) … Follow the instructions to the letter and it’s as simple as making a roast chicken…
If you build the engine via visual studio 2013 express desktop , (also free) it comes as a standalone system, that doesn’t require the launcher or an internet connection once installed. In all, it’s about two hours work for a cumbersome free adventure into the engine, (and the added bonus that you built UE4 from just c++ source files )

I know nothing, (absolutely zero) about coding but I managed to do it. The main reason because I sometimes lose the internet for days in my remote village in Scotland

Dave

Hello,

Our specialists have been made aware of this issue and are working on a resolution. We will have a response soon. Thank you for your patience.

Has any progress been made on this issue? We are in the evaluation process right now, and when I use UE4 at home it is fantastic but if we can’t launch it in our office then it is not a viable option.

Hi mr_pinc,

We are still working on solutions for this, both short-term and long-term. To help towards that, would you mind please uploading your launcher logs here for us to review?

  • Navigate to the DefaultEngine.ini file

  • C:\Program Files\Unreal Engine\Launcher\Engine\Programs\NoRedist\UnrealEngineLauncher\Config\DefaultEngine.ini

  • Open in a text file and add to the very end of it (without the gaps between):

    [Core.Log]

    LogHttp=log

    LogOnline=verbose

Reproduce the issue again to generate the logs. Find them here, C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs and attach in a zip file.

Thanks!

Here you go per your request

Thanks for the logs,

We have a few more questions about your setup.

  • Does your company use an HTTP proxy or an HTTPS proxy?
  • Have you received any information from your IT department regarding what the exact issue may be, and if they are deliberately blocking this type of traffic?

We appreciate your support with this.

From my understanding the Proxy supports both protocols. I have no information from my IT department - it’s well beyond my reach. I would not say they are deliberately blocking traffic - its just that connecting via http requires a web authentication.

Interestingly though, Node Package Modules is able to work just fine. There may be certain URLs that are white listed but I am just guessing there.

I can give you more details if you care to contact me privately.

I’ve put in a request to have epicgames.com removed from the authentication process.

It turns out that the main proxy actually blocks epicgames.com entirely.

Now I might be able to unblock for my use / my team’s use but this could prove problematic for other users.

Access through the Launcher is not currently possible behind proxies, but we are investigating solutions for this. In the meantime, for any users who are experiencing this issue, please comment below to let us know. We may request additional information and discuss possible arrangements with you.

Cheers

FYI, adding epicgames.com to our proxy exception list worked fine for us.

If you use Mac or Linux, you can easily enforce the use of a proxy for specific or all the traffic; one method is to use iptables. If you use Windows, there are many programs that do that for you. I personally use and suggest Proxyfier: light, easy and flexible.

hi…
after upgrade launcher to 2.0.0-2465596 i can’t use my proxifier to login …
after a minute my proxifier detect an infinite loop from Launcher and block it …
How i can fix this …
using windows 8.1 pro

Hi Vahid,

The issue that you are describing is related, but rather different from the original post here. Could you create a new thread via “Post a Question” and make that an Installation and Setup issue? That will allow me to assign a technician to look into the report and help get a resolution.

Thanks!

Hello,

Try adding " -http=wininet" at the end of the Target path. Im in a close network that uses proxy settings, so my network settings is set up manual with proxy and it worked for me.

Hi, I’m still stuck with this problem.
I setup the proxy address in the settings x.x.y.y:port
I also added http://epicgames.com/ to the proxy exception list.

But it still does not help, I still cannot process to the Sign in page.
Do you have any solutions on this problem?

I have the same problem Can’t run the launcher with company proxy.