Download

Is it possible to change the size of the font of the UI for high DPI monitor?

Can I change the font size like UE4 in UE5 especially for high DPI monitor?

2 Likes

I can’t seem to find any equivalent way to do this in UE5 either and find the text far too small to read comfortably. Surely, there has to be a way to increase the font size?

Hi @Stevenmbiz and @TFX_Mech_Guy. There is a Long thread High resolution display support for editor - Unreal Engine / Feedback for Unreal Engine team - Unreal Engine Forums

This goes into so much detail. I think the last post may be what you are looking for

Update:- Here is my answer for UE5 EA2 and Win 10.
For Windows 10 Unreal 5 EA 2 Source Version
built with Visual Studio 2019 Community version 16.10.. onwards

In file explorer right click on UnrealEditor.exe.
Send Short cut to desktop. Right-click the shortcut
Replace the target line with You need a single quote at beginning of the line and a single quote at the end.
After the end quote put a space and type -enablehighdpi.

“C:\Users\Owner\source\repos\ue50EA\Engine\Binaries\Win64\UnrealEditor.exe” -enablehighdpi

Click the Apply button to save this, then the OK button.

Now double click the shortcut.
In the Games, section Select the First Person Shooter to give Project name like EnableHighDpi.
Click ok. ALL the Shaders should re-compile >4096.
The Project will open. My GTX card is a 2GB Dedicated so UE5 is already complaining about the lack of GPU Video Memory.

It works on my Ultra HD display, but the graphics card is struggling now all >10,000 shaders have been re-compiled.

If it still does not work try Editor Preferences → General → User Interface → Enable High DPI support. Switch it on (tick), try the project again. Turn off then turn on.
NOTE:- When you import a UE4 project to UE5 this is OFF by default! unless set in a UE4 project

Have you ever used Editor Preferences → Level Editor → Play → Game Viewport Settings
In New View Port Settings-> Drop down Common Settings → TV and set 4K Ultra HD 3480 x 2160 or even 4K Digital Cinema 4096 x 2160.
When you click Play, probably break your graphics card :slight_smile:

3 Likes

Thanks for taking the time to provide such a detailed reply, that’s very much appreciated. I’ll take a look at this when I get some time this evening. The solution I used in UE4 was to access and modify the settings found in: Developer Tools > Widget Reflector, but I can’t find this setting in UE5. In case this makes any difference, I’m also using UE for non-games purposes too. Therefore, I haven’t used or attempted to modify any specific “game” related settings. I’ll take look and let you know if this works for me. Thanks again, much appreciated.

Hi @TFX_Mech_Guy, You asked

The answer is to use the key sequence together of “Control + Shift + W”, the first thing when your project blueprint has opened up.

I found this using my skill of searching and reading the source code, but this will never match your artists skill to produce these wonderful projects.

Just to confirm, we need to know how to increase the size of the text in the UI . I already have the “enable high DPI support” option enabled too. This was quite straight forward in UE4 using the settings found in the Widget Reflector which scales the entire interface like in Blender. Blueprints aren’t always required for non-games projects so perhaps you are misunderstanding what we are trying to achieve?

I have been inside the engine looking at all the settings and fonts then realised I could set this from the project settings


None are set by default.
Then I was directed to the UE50EA fonts.
In the comments, it’s implied that you change the startup fonts from Robo.Small to Robo.Large, but the names do not seem to correspond
loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Regular.ttf’ (155K)
loaded font ‘…/…/…/Engine/Content/Slate/Fonts/DroidSansMono.ttf’ (77K)
The full list is

Therefore if you rename Roboto-Medium.ttf to Roboto-Regular.ttf
You increase the size, but it’s just a hack! and you will permanently change the Font to ALL the Unreal processes, but there is no control on the Font size!

Tried but it won’t work, hopefully, it comes as the default feature. So far nearly all other engines and content creators including Blender can do this perfectly.

@Stevenmbiz @TFX_Mech_Guy
I have since having looked at another post.
Problem with high dpi scaling monitors - UE4 AnswerHub (unrealengine.com)
Solved 4K Scaling Win10 Unreal 4.26.0 with Sharp Text and Sharp Demo FPS using alt + p

Before starting double check your settings and make sure these settings are changed first before applying the method.

Right click on the Unreal Engine “Shortcut”> Properties > Compatibility. UnCheck the box for “Override high DPI scaling behavior.” And yes, uncheck is correct for what we are going to do.

Open Unreal Engine > you may select a new project or current one you have > Click on Edit > Editor Preferences > Make sure “Enable High DPI Support” is Checked.

General > Performance > “Disable DPI Based Editor Viewport” is Checked.

Go ahead and Close Unreal.

Method Setup :

Right Click On Your Desktop and Select Display Settings

Left Click On Your 4K Monitor it should be labeled 1 or 2.

Scroll Down To “Scale and layout”

Click On The Drop Down Menu For “Change the size of text, apps, and other items”

Select 300% Recommended (My setup works with 300% which is the recommended yours might be different but use your own recommended.

Click on “Advanced scaling settings”

“Let Windows try to fix apps so they’re not blurry” Switch This To “OFF” and close the window.

Open Unreal Engine > Click on “Window” at the top left. Click on Developer Tools > Widget Reflector > Application Scale: Change from 1.0 to 0.8 and hit Enter.

Now your Windows apps will be correct size plus Unreal Engine will be correct size with non blurry text and also do alt + p for the FPS demo and that should be sharp as well.

I hope that helps some of yall. I thought something like this would be fixed by now.

-Matt

more ▼

answered Dec 28 '20 at 2:09 PM

avatar image

PingNasty
6 ● 1 ● 4

avatar image Jimbohalo10 12 minutes ago Newest

This excellent. I would add that my Red Eagle monitor says it supports HDR and 144 HZ.

It’s on an Nvidia GTX 1050 and the Windows profile was set for 60HZ, I don’t know how I didn’t change this earlier now I can go to with 150% as I am on a 23-inch monitor
The last entry deals with UE and Win 10

I have noticed that the Enable Editor Support for HDR Monitors.
I forgot to enable 144hz Refrsh in Windows 10, which I have done now.


@Stevenmbiz @TFX_Mech_Guy _Mech_Guy
Finally I tried on the 4K UHD at 300%, but gone back to my 23 inch 4K with 150 %.

I agree it would be better if UE5 was -enablehighdpi all the time and worked, but we just have to try different ways