IPP ERROR: Could not find provision directory

Hi Guys,

I really need your help with this error.

When i start a new project, i got this message in the output log :

LogSlate: Took 0.000540 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Editor/Slate/Fonts/FontAwesome.ttf’ (139K)
LogTemp: Executing iPhonePackager certificates Engine -bundlename com.YourCompany.MyProject
LogTemp: CWD: D:\divertissement\Jeux-Gaga\UE_4.20\Engine\Binaries\DotNET\IOS
LogTemp: Initial Dir: D:\divertissement\Jeux-Gaga\UE_4.20
LogTemp: Env CWD: D:\divertissement\Jeux-Gaga\UE_4.20\Engine\Binaries\DotNET\IOS
LogTemp: BranchPath = DESKTOP-JGDBOP2/D/divertissement/Jeux-Gaga/UE_4.20/Engine/Binaries — GameBranchPath = DESKTOP-JGDBOP2/D/divertissement/Jeux-Gaga/UE_4.20/Engine/Binaries
LogTemp: IPP ERROR: Could not find provision directory ‘C:\Users\yvesg\AppData\Local/Apple Computer/MobileDevice/Provisioning Profiles/’.
LogRenderer: Reallocating scene render targets to support 968x484 Format 10 NumSamples 1 (Frame:1).
LogSlate: FSceneViewport::OnFocusLost() reason 2
LogSlate: Window ‘Tutorials’ being destroyed
LogContentBrowser: Native class hierarchy updated for ‘HierarchicalLODOutliner’ in 0.0003 seconds. Added 0 classes and 0 folders.
LogLoad: (Engine Initialization) Total time: 12.90 seconds

I have UE4.20.3 and UE4.21.2 engines installed, on both the same error happens.
The project that i’m working on is for Oculus Go, from what i understand, this error i Apple related, and i don’t need IOS implementation.
Because i don’t have any Apple device, i can’t receive this “provision file”, but i should’nt need it at all.

Same 4 me… do you know solution?

hey,
https://answers.unrealengine.com/questions/770057/ios-packaging-for-distribution-problems-ipp-error.html
go through the above link. this might help you.
regards!!

I fixed this by deselecting [IOS], [Mac] and [tvOS] in “Project Settings/Project/Supported Plattforms/”.
Close the ue4 project, and reopen it.
Change the settings back to [All Platforms], close and reopen the project again.
In my case, no “IPP ERROR” when open the project.
(even though the directory ‘C:\Users\yvesg\AppData\Local/Apple Computer/MobileDevice/Provisioning Profiles/’ does not exists)

I’d also change the “Apple Computer” folder to not include the space.

There’s a really good chance it’s passing a file path to the command line in a way that doesn’t properly escape the spaces in folders, causing it to not find the folder. I’ve had that happen to me at least once, because my main Unreal folder is called “Unreal Projects” – the space breaks everything. So I changed it to UnrealProjects and everything builds fine now.