iOS - So Over Complicated!

Hi all,

I’ve been trying to get a very basic app to test on my iPhone - wow it’s so crazily complex!

I was working on a BP only project as originally I just wanted to make it on my PC and remote build it to my phone, however I got hold of a Mac to test with and so it’s now on there, still just a BP project.

I’ve registered with Apple for an account, used it to create the certificates, profiles etc which UE seems happy with initially. However the builds always fail due to not having teams (I don’t even have a team option in Xcode?) but I have my AppleID on there as an account, but that doesn’t work and also failing to connect to my bundle… I was doing this for someone else and really need to get it working but as I’m not a Mac user I’m really struggling with all of their stuff.

Is there a simple way to get it to even just test on my phone? I can’t believe this is the standard way to go about doing this…

You need to show your setup in project settings. otherwise no one can tell, what’s wrong.

The easiest way is to create a new project with XCode with the same project name as your UE4 project, choose automatic signing, let it handle everything.
No need to use this project in any way, it’s only purpose is to handle the whole singing on the Mac.

Then make sure you set the exact same name, profile, certificate etc. in the UE4editor project settings.

Hi NobbigvonL,

A big part of my problem is having to move over to using Xcode/Mac at all. Everything works in such a subtly different manner.

However I will look at whether my xcode project is automatically signing or not - that may well be the key. I really appreciate the reply.

Which bit in particular would help you help me? I really appreciate any guidance on this so tell me what you’d need to see and I’ll do my best to get it.

I’m now at a point where I get this error code on compile:
Code Signing Error: UE4 has conflicting provisioning settings. UE4 is automatically signed, but provisioning profile [long identifier] has been manually specified. Set the provisioning profile value to “Automatic” in the build settings editor, or switch to manual signing in the Signing & Capabilities editor.

In my UE4 build settings on iOS I have no provisions or certificates selected. I have automatic signing selected.
In my XCode project I have “Automatically manage signing” selected in Signing and Capabilities.

Am I looking in the wrong places?

You misunderstood. Don’t turn on automatic signing in the UE4 editor or it’s xcode project. Create an** empty Xcode project, with the same name and let it handle signing.**
This is easier than manually setting up profiles and certificates at the apple developer website and then installing the certificate on your Mac.

  1. XCODE

Open XCode without UE4, only XCode. Create a new project, that has nothing to do with UE4. It is an empty dummy project that you only use to let xcode automatically setup certificates and provisioning profiles on that mac.
It will help you to set up your mac and everything at the apple developer account, that you would normally do when logged in at the apple developer site.

When you create a new project in XCode it will show you bundle-id, team-id and so on. Write it down, to enter it in UE4 editor project settings. (Where to find automatic signing in XCode is easy to google.)

Then close XCode, don’t use this empty Xcode project anymore.

  1. UE4

Then open your UE4 project, do not choose automatic signing here in UE4. The empty dummy Xcode project already set up everything.
Make sure you set the exact same certificate, provisioning profile, and the same bundle identifier like in the separate Xcode project from before.

Separate XCode empty project and your UE4 should have the same project name.

Be aware of the distingtion between a developer certificate and a distribution certificate to publish on the app store. Read apple documentation for more info. Good luck

You sir are amazing. I will give this a go and I massively appreciate you taking the time to write this up for me!

Hope it helps, good luck!