iOS Remote Build - Failed to connect to UnrealRemoteTool

Using 4.9 source build on Windows and I’m having trouble packaging to iOS. My project is blueprint only and I assume you have to use the remote build with the source build even if I have no code in the project?

I’ve successfully setup the remote build settings using this guide: Unreal iOS remote build - Mobile - Unreal Engine Forums. The generate ssh was able to connect fine and I can connect by ssh fine to my mac but when packaging I get “MainFrameActions: Packaging (iOS): UnrealBuildTool: Failed to connect to UnrealRemoteTool running on”

I’ve attached full log also. I also deleted the DerivedDataCache, Intermediate, and Saved folders before opening the project in the source build.

Edit: Using the same ssh key a new project connects to the mac after I added code but it fails later with a different error. Do I have to add code to the project? I added code and it still gets the same error anyways.

One other thing I noticed under the Remote Build Options of my project only the Remote Server Name isn’t grayed out. I can get to the other options by tabbing to them but I can not click on them. Under the new project the settings are not grayed out and I can click on them.

Edit2: I noticed the command options are different in the new project and I tried running UnrealBuildTool from the command line with those options for my project and it gets failed to connect but for the new project the command line build connects.

link text

I’ve resolved this by using the DefaultEngine.ini from the new project and copying basically just the GameMapSettings from the DefaultEngine.ini in my project then the options were not grayed out and it would connect.

I’ve run into new problem though. This is the last line:

PackagingResults:Error: Error Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac.

I only have one certificate that I created on the mac which I have exported to my windows machine also. The certificate is in the login and system keychain on the mac. So I’m not sure why it doesn’t see the certificate.

link text

I got the certificate issue fixed and it packaged fine. I had the certificate in the system keychain but didn’t have the private key with it.

Probably missing what you are saying but I thought you could build non source code iOS projects on a PC. The little iOS packaging I’ve done on PC required itunes to be installed.

I have the same issue! Can you help me? What do you mean when you say “but didn’t have the private key with it.”? How can i get privat key and fix this problem.

I just remember something about in Keychain Access on the mac the certificate was there under system but the private key was not.