iOS - Provisioning and certificates (MacOS)

I’m developing a mobile game (for iOS) and so I bought a new MacBook Pro in order to be able to make a distribution package (however game is not ready yet). I’m using Unreal Engine 4.22.3. I started developing that game on Windows and then I switched to MacOS (6 days ago). I zipped the project using the option in the packing options. And currently I’m stucked with provisioning and certificates, It worked on Windows perfectly, but on MacOS I’m not able to get it working (quite funny considering that I’m developing from one Apple platform to another, but that’s how it is). So, what’s the problem? Well, I started with my old certificates and provisioning, that didn’t work (they didn’t show up). So I went to the keychain, get a request for new certificate and went trought all that process again. Well, It didn’t work either, the certificates and provisionings didn’t show up. So I went to the xCode, created a new project, compiled it and deployed it to my mobile. Then I went to Apple Developer site, downloaded the certificate and provisioning and tried importing it, and still it didn’t work. I should mention that I changed bundle Indetifier every time I uploaded certificate or provisioning with different bundle identifier. I also tried automatic signup, which didn’t work (currently when I press launch on iOS device the engine starts to look like It is doing something, but then It crashes). So, I’m a bit stucked now. So my question is, how to fix it?
I’ll be thanfull for any help.



I tried installing XCode 10.3 and It worked.