Download

iOS - Provisioning and certificates (MacOS)

Hi,
I’m developing a mobile game (for iOS) and so I bought a new MacBook Pro in order to be able to make a distribution package (however game is not ready yet). I’m using Unreal Engine 4.22.3. I started developing that game on Windows and then I switched to MacOS (6 days ago). I zipped the project using the option in the packing options. And currently I’m stucked with provisioning and certificates, It worked on Windows perfectly, but on MacOS I’m not able to get it working (quite funny considering that I’m developing from one Apple platform to another, but that’s how it is). So, what’s the problem? Well, I started with my old certificates and provisioning, that didn’t work (they didn’t show up). So I went to the keychain, get a request for new certificate and went trought all that process again. Well, It didn’t work either, the certificates and provisionings didn’t show up. So I went to the xCode, created a new project, compiled it and deployed it to my mobile. Then I went to Apple Developer site, downloaded the certificate and provisioning and tried importing it, and still it didn’t work. I should mention that I changed bundle Indetifier every time I uploaded certificate or provisioning with different bundle identifier. I also tried automatic signup, which didn’t work (currently when I press launch on iOS device the engine starts to look like It is doing something, but then It crashes). So, I’m a bit stucked now.
I’ll be thanfull for any help.

Windows:
http://airsoftmodra.cz/image/windows.PNG

MacOS:
http://airsoftmodra.cz/image/mac01.png
http://airsoftmodra.cz/image/mac02.png
http://airsoftmodra.cz/image/mac03.png

Are you going into XCode Preferences -> Accounts and clicking “Download manual profiles”? This is how you get the profiles from the website to your Mac.

Also make sure you’ve installed XCode 10.x. If you’ve installed 11 then you need to install the old version and select it as the console version in the settings. Check the stickied posts for info on how to do this.

What engine version are you using, are your certificates and provision showing up at all or not (and that is the issue)?

i went through the guide for creating a new certificate on apple and it loaded just fine first time!

So I tried installing XCode 10.3 and It worked. Thanks, you saved me a lot of time.