IOS Packaging : keyset does not exist

Hello, I already posted my problem on unreal answers, but I really need help as soon as possible so giving myself all the chances I can get.

I’ve spent the last 2 days trying to package on pc without success. For now I am not even trying to package my project itself, I’ve been doing tests on an empty blueprint project in 4.19 with only an empty map in the content folder.

However every time I try to package I end up with the error “Keyset does not exist”. I tried multiple times to delete both certificate and provisions and try again in case either was corrupt, but without any luck.

I also tried importing the certificate directly in the manager, but there again it did nothing.

If anyone has any input, I would be very grateful.

Thank you.

Still unresolved.

are your provisions/certs valid? , are those development ? maybe you could share your log? use


Yes both are and yes, testing development for now.

Here is the package log and and screenshot of my provision and certificate.

Thank you

Give it a try on new 4.20 , are you trying via remote mac or a mac ?

Was about to try just that, and neither it’s a full blueprint project, so packaging directly on pc. Will let you know if it works.

It worked ! No idea what wasn’t working with 4.19, but now I can package. Stumble on other problems, of course, but at least that part is working !

Thank you for the support.

I had the same problem.
I was helped by the third step from this site:…oes-not-exist/
The problem is that when importing a certificate, UE4 launches iPhonePackager on behalf of the current user. If the user does not have administrator rights, then he cannot write the keys to the folder C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys.
You need to provide full access to that user on the folder “C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys”.
After that you need to reimport the certificate.


Wow, dude, thanks. This saved me so many hours of frustration. Such an obscure error…