iOS Packaging for distribution problems IPP ERROR: Failed to find a valid matching mobile provision

my game is finally ready to publish so I am trying to compile it and upload it to AppStore,
on GooglePlay I already have it all ready in alpha testing phase.

I am using a Macbook Pro late 2010 to remote compile from windows 7 where I run Unreal Engine 4, version 4.15.3 .
When I was first setting this up I didn’t run into much problems with “development” provisioning profiles, I simply created everything like it is explained, downloaded the certificate to my Mac and double clicked it, then exported the Certificate from keychain, as p12 file and downloaded the .mobileprovision to my PC, imported it and voila.

Now that I created a distribution certificate and the rest, I can’t seem to make it work, on my Mac everything is same as setting up a development certificate and provision, I repeat the process on my Macbook Pro and copy files to PC, but IPP doesn’t want to import it, I read somewhere about a bug that takes 24h for the certificate and provision to work , so I waited and still the same problem. I recreated everything several times in last few days, and nothing seems to work, earlier today I somehow managed to import from the editor, probably because the certificate was already in when I was trying it with IPP earlier, but the mobileprovision wasn’t accepted by IPP, I also copied the 2 files into project/build/ios folder, and then I could hit Package-iOS.
What happens is I get this error link text

I also tried to go through this process on windows, so I generated a signing request, and followed the instructions, and this does seem to work on PC right until the remote compile part because I can’t import the key pair I created on PC to my KeyChain. Therefore on my Macbook pro there is no Key in the keychain, and I assume when it starts to compile the xcode it will give an error. I guess this is why creating provisions on PC method is only for blueprint projects.

So I guess on my last try I got this error again in the IPP this time:IPP ERROR: Failed to find embedded plist in .mobileprovision file

Yes I know that I can clear my certificates running certmgr.msc on PC, under Personal-Certificates,
and I deleted the provisions several times in
C:\Users\Jurij\AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles .
I also know that bundle identifier com.jurij.mygame has to match.
I am running out of ideas because I am pretty sure I tried all the combinations, recreated the Distribution certificate 4 times, and made 4 different mobileprovisions for distribution, nothing worked, I even tried to name the mobileprovision files to match the project name.
The only thing I did not yet mess with is the plist file, and the bundle name setting, does that thing matter?

Anyone has any suggestions or ideas?
I will post results if I find the solution, I have about 10 days left I think because since April 2018 all new apps will have to be compiled with iOS 11 SDK which would mean I’d have to update my project to newer UE4 version, and also the plugins and so on, which would likely mean more bugs with any of the plugins and more time to fix everything.

It seems I was doing this wrong the whole time, because I deleted all the provisions and certificates several times,
what I did now is first I imported the development mobileprovision and certificate , then I imported the Distribution mobileprovision and certificate and this way it gets accepted. I tried to compile with distribution cert. and get an error:

PackagingResults:Error: Error Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac.
So I double checked everything again, deleted all certificates, mobileprovisions, and restarted my PC and Mac,
then I first imported only the development cert. and provision, and again it compiled fine, then I imported the Distribution cert. and provision and made sure they are checked-selected in the editor- project settings-ios, and I get the same error.
Which doesn’t make sense since the development version compiled so clearly the problem is with distribution certificate on the Macbook, yet the files I imported on PC were exported from Macbook’s keychain… We’ll I’m still trying… And keep getting this error
Make sure your developer certificates have been installed in the System Keychain on the remote Mac.
Well clearly I need to focus on that part again, what I don’t get is when I read the logs it first checks the distribution provisions and it says
Phase 0 considering provision ‘Distro_Jumpy_Frogs.mobileprovision’ named ‘Jumpy Frogs’
UATHelper: Packaging (iOS): UnrealBuildTool: … Failed debugging check (mode=False, get-task-allow=False, #devices=0)
then it checks the development one and it selects it, and soon after that I get that error…

Ok to sum this up I tried so many things today it’s gotten really confusing, I just don’t get it why I can’t simply import the distribution cert and provision without the development one. My best guess since I tried everything else is to try this tomorrow with the free version of my app (I made paid and free version), which has a different name prefix before the com.jurijxxx.jumpyfrogsfree part, and this may be because the original app profile is like 7 years old and when I was creating the free app profile few days ago, I couldn’t select the same prefix… I don’t know I need to go sleep and get back to this with a fresh head.

I’ve got a similar problem. Development builds compile just fine, but building for distribution is impossible.
This didn’t work in 4.18 for me, and 4.19 as well.

WOOHOO, I think I found the solution, yes all the problems above are true, but instead of compiling with the distribution certificate and provision, there is an easier way, just compile it with Development provision and cert, and then use the “Re-sign an IPA” tool in the IPP-Advanced tool tab, you also have to check the “compress modified files” in the settings, manually set the provision and certificate and it worked the first time I tried, I uploaded using “Application Loader” on mac, and it got accepted, now the app is on AppStore ready to be tested. Considering all the things I tried in last 3 days and time and nerves wasted, I really want to make a video tutorial about all this so others can avoid these problems, but first things first, I need to finish this up and make sure everything really does work and get the game published. If this wouldn’t have worked I would probably sell this Macbook and buy a newer one that supports Metal shader.

sounds good, I’ll give it a try :slight_smile:

Worked for me!! THX

I’ll try this! Thx!!