Download

iOS Packaging for Distribution: Build failing

Hi, since I cant seem to get an answer on AnswerHub or find any relevant information, I’m going to just go ahead and start a new thread here.

I’m currently wrapping up development on my first iPhone / Android game utilizing UE4. I’m excited and its become pretty fun and can’t wait to share it with everyone.

I’ve been running into a problem though thats been frustrating me for the past couple of days.

Every time I package and build my game with “For Distribution” checked, the game will always crash on the splash screen after being deployed to my phone. It never seems to fail. To clarify, I’m on 4.10.1, can check the correct provisioning file (in this case, I have three - One for Dev, one for Ad Hoc Distribution, and one for straight up App Store Distribution; both distro builds fail).

It seems essential to be testing these distribution builds as they generally are lower file sizes (like 87mb~) and I want to make sure they are good to go before sending off to Apple. Other builds, like Development or Shipping (without “For Distribution” checked) are in the 140mb file range.

I cant seem to generate any “Backup Files” or crash logs to get off the phone either… nothing from iPhone Packager is generated when I try to retrieve them either.

What could possibly be going wrong here? I’m eager to get my build out the door and into peoples hands. If there is any additional information I could include to help people understand whats going on or possible see more into it all, please let me know!

Thanks!

  • Lucas Govatos

Hi Lucas,

  1. Your game, how complex it is? care to share some screenshot?

  2. Which iPhone/iPad are you using?

  3. ‘After being deployed’ Did you mean, after you installed it as an .ipa via iTunes?

  4. You didn’t mention about any test result for development/shipping (without for distribution checked) so I can assume all the other build test is a success?

  5. Are you using GameCenter/leaderboard? and if yes, does it at begin play in the firstmap?

Based on the file size and the crash, are you sure you are including all maps in district build?

Check packaging settings and manually include maps if needed

Hi Lucas, if it’s you’re first app this stage of development can be confusing and stressful, relax everything will be just fine.

I may be wrong so anyone please correct me if so. But from my experience of developing for iOS you cannot deploy or install locally to you’re device an app that has been built for distribution. You must upload it to iTunes connect and download it to you’re device from the App Store or maybe TestFlight.

Let me know when its available and I’ll give it a rating

Hey there,

  1. The game is not too complex - just two maps (main menu and a base level). Heres a bit of an older screenshot, although its missing a lot of stuff. I’ll get some more soon to share before release :slight_smile: http://imgur.com/i6e4XRO

  2. Test devices range from an iPhone 5, iPhone 6, and also an iPad Air

  3. By deployed, I meant from iPhone Packager. I build it in UE4 and then install the Distro build to the device using it.

  4. I’m not using GameCenter.

Heres my current packaging settings in Project Settings. My maps are included under the list of maps to include in a packaged build.

2ec0f1ffeed2cb9dbfb34339b2f2a033f5f4f667.png

Lastly - Alan, I have not tried that yet. I’ll see if I could get that working also and give it a shot. Thanks :slight_smile: Just want to mention also, I’m running on Windows. I do have access to a Mac but it wont be until later.

Hi Hiyguy8000,

  1. By deployed, I meant from iPhone Packager. I build it in UE4 and then install the Distro build to the device using it.

I really don’t quite get this, because the way I’m testing my iOS game - for distribution build is to make sure I installed iTunes in my windows, package the game into .ipa, connect my device and make sure it is recognizable/usable in my iTunes windows, then double click the .ipa, -> visible in the iTunes and do ‘Sync’ / ‘Will Install’

I’m sorry, maybe I’m inexperienced or a n00b, I haven’t tried ‘deploy’ directly my iOS packaged from the editor or iPhone packager (non-github-build) onto my iphone 4s/6+/iPad3 from iPhone packager. I usually ‘deploy’ or install it via iTunes, AFTER I successfully build the .ipa

Hey RynerAJ, I tried installing through iTunes but I’m getting the same problem. App still seems to automatically close upon starting up. Going to try resigning the app on a mac and install it through there and see what results I get… but not totally sure if that will resolve the issue.

Hi Guys, once you’re app is packaged signed for “distribution” it must be installed from the AppStore. it will not work if deployed or installed locally through iTunes
you must upload the distribution .ipa to iTunes Connect.

Hey Alan,

I tried uploading my project from a Mac through Application Loader. I ended up receiving the error “Missing Provisioning Profile - Apps must contain a provisioning profile in a file named embedded.mobileprovision” ? I opened up the IPA on windows and that file is definitely there. Would this go back to the problem of the Distribution build being cooked and packaged on a windows machine? If so, would it simply be possible to copy over the entire project directory on the mac and recook and package there?

So a small update: I’ve finally been able to get it uploaded to the App Store. Unfortunately though, the build says its “Missing Beta Entitlement”. How do you activate this? Is there something you have to do through unreal? The build is like grayed out in when I try to add it as a version under Test Flight for internal users.

E: so after finding out you have to use a regular appstore distribution mobile provision instead of adhoc to get the beta entitlement, i was able to download it to my phone from TestFlight. However, with that said, its still crashing upon startup on the splash screen. I’m thinking some files are not being included. I’m using the same settings as posted above, is there something else i should try?

Hi again, adhoc provisions are for development use only. Have you tried enabling “cook everything in the content directory”?
I’ll be uploading a project myself this weekend using 4.10.1 I’ll let you know if it works for me

Answer to an earlier question is yes you can transfer your projects between Windows and OS X, just copy the entire project directoy and its contents or you zip and share directly from the editor.

Hi Alan!

I tired doing a “Cook everything in the content directory” and its still producing the same error.

Finally got it working. The size went up but thats fine. Unchecking the “Use PAK File” in the packaging settings made it start working after being built…

cool, glad you got it working.
I’ve just packed a game for distribution uploaded to iTunes connect and installed it using test flight test flight and its working fine for me.
my development packaged game size was 166mb
distribution packaged game size is 143mb
i have “Use PAK File” enabled