Download

iOS Packaging error on Mac

I’m packaging my project for iOS from my Mac, after failing to package from my Windows PC for over 2 weeks. My packaging attempts from my mac seem to fail sooner than from windows. I keep getting an UnrealBuildTool error, and when I go into the log file I can’t find any reference to an error with anywhere to go to fix it. This is a pure blueprint project with no C++ classes apart from a couple of plugins from GitHub. This is my error log:


LocalExecutor.ExecuteActions: Performing 26 actions (4 in parallel)
ActionThread.ThreadFunc: [1/26] Compile SharedPCH.Engine.h
ActionThread.ThreadFunc: [4/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/AdsUtil.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/FacebookAds/AdsUtil.embeddedframework
ActionThread.ThreadFunc: [2/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/UnityAds.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/Unity/UnityAds.embeddedframework
ActionThread.ThreadFunc: [3/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/AdsUtil.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/Unity/AdsUtil.embeddedframework
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/FacebookAds/AdsUtil.embeddedframework.sh: No such file or directory
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/Unity/AdsUtil.embeddedframework.sh: No such file or directory
ActionThread.ThreadFunc: [5/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/FBAudienceNetwork.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/FacebookAds/FBAudienceNetwork.embeddedframework
ActionThread.ThreadFunc: [6/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/GoogleMobileAds.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/AdMob/GoogleMobileAds.embeddedframework
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/Unity/UnityAds.embeddedframework.sh: No such file or directory
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/FacebookAds/FBAudienceNetwork.embeddedframework.sh: No such file or directory
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/AdMob/GoogleMobileAds.embeddedframework.sh: No such file or directory
ActionThread.ThreadFunc: [7/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/AdsUtil.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/ChartBoost/AdsUtil.embeddedframework
ActionThread.ThreadFunc: [8/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/Chartboost.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/ChartBoost/Chartboost.embeddedframework
ActionThread.ThreadFunc: [9/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/AdsUtil.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/AdMob/AdsUtil.embeddedframework
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/ChartBoost/AdsUtil.embeddedframework.sh: No such file or directory
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/AdMob/AdsUtil.embeddedframework.sh: No such file or directory
ActionThread.ThreadFunc: [10/26] sh Unzipping: /Users/ikeapax/Documents/GitHub/KeepItUp/Plugins/AdCollection/Source/ThirdParty/ThirdPartyFrameworks/CHAMoatMobileAppKit.embeddedframework.zip -> /Users/Shared/Epic Games/UE_4.22/Engine/Intermediate/UnzippedFrameworks/ChartBoost/CHAMoatMobileAppKit.embeddedframework
ActionThread.ThreadFunc: [11/26] Compile SharedPCH.Core.h
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/ChartBoost/Chartboost.embeddedframework.sh: No such file or directory
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/ChartBoost/CHAMoatMobileAppKit.embeddedframework.sh: No such file or directory
ActionThread.ThreadFunc: [12/26] Compile KeepItUp.cpp
ActionThread.ThreadFunc: [13/26] Compile Module.VaRestPlugin.gen.cpp
ActionThread.ThreadFunc: [14/26] Compile Module.VaRestPlugin.cpp
ActionThread.ThreadFunc: [15/26] Compile Module.AdCollection.gen.cpp
ActionThread.ThreadFunc: [16/26] Compile Module.AdCollection.cpp
UnrealBuildTool.Main: CompilationResultException: Error: OtherCompilationError
UnrealBuildTool.Main:   at UnrealBuildTool.ActionGraph.ExecuteActions (UnrealBuildTool.BuildConfiguration BuildConfiguration, System.Collections.Generic.List`1[T] ActionsToExecute) [0x000a5] in <81d2c224e1e3472d9b857079a6928c09>:0 
UnrealBuildTool.Main:   at UnrealBuildTool.BuildMode.Build (System.Collections.Generic.List`1[T] TargetDescriptors, UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.ISourceFileWorkingSet WorkingSet, UnrealBuildTool.BuildOptions Options) [0x00235] in <81d2c224e1e3472d9b857079a6928c09>:0 
UnrealBuildTool.Main:   at UnrealBuildTool.BuildMode.Execute (Tools.DotNETCommon.CommandLineArguments Arguments) [0x002cc] in <81d2c224e1e3472d9b857079a6928c09>:0 
UnrealBuildTool.Main:   at UnrealBuildTool.UnrealBuildTool.Main (System.String] ArgumentsArray) [0x00291] in <81d2c224e1e3472d9b857079a6928c09>:0
Timeline.Print: Timeline:
Timeline.Print: 
Timeline.Print:  0.000]
Timeline.Print:  0.000](+0.122) <unknown>
Timeline.Print:  0.122](+0.004) FileMetadataPrefetch.QueueEngineDirectory()
Timeline.Print:  0.126](+0.313) XmlConfig.ReadConfigFiles()
Timeline.Print:  0.439](+0.000) SingleInstanceMutex.Acquire()
Timeline.Print:  0.439](+0.062) UEBuildPlatform.RegisterPlatforms()
Timeline.Print:   0.442           0.002](+0.036) Initializing InstalledPlatformInfo
Timeline.Print:   0.478           0.038](+0.000) Querying types
Timeline.Print:   0.479           0.040](+0.007) MacPlatformFactory
Timeline.Print:   0.487           0.048](+0.003) TVOSPlatformFactory
Timeline.Print:   0.491           0.051](+0.003) AndroidPlatformFactory
Timeline.Print:   0.494           0.055](+0.001) IOSPlatformFactory
Timeline.Print:   0.496           0.056](+0.002) HTML5PlatformFactory
Timeline.Print:   0.498           0.059](+0.000) LinuxPlatformFactory
Timeline.Print:   0.499           0.059](+0.002) LuminPlatformFactory
Timeline.Print:   0.501           0.061](+0.000) WindowsPlatformFactory
Timeline.Print:  0.505](+0.006) TargetDescriptor.ParseCommandLine()
Timeline.Print:  0.511](+0.059) <unknown>
Timeline.Print:  0.571](+8.792) UEBuildTarget.Create()
Timeline.Print:   0.572           0.001](+8.371) RulesCompiler.CreateTargetRulesAssembly()
Timeline.Print:   0.572            0.001           0.000](+7.169) <unknown>
Timeline.Print:   7.741            7.170           7.169](+1.124) Finding engine modules
Timeline.Print:   8.865            8.294           8.293](+0.005) Finding plugin modules
Timeline.Print:   8.870            8.299           8.298](+0.048) <unknown>
Timeline.Print:   8.919            8.348           8.347](+0.016) Finding program modules
Timeline.Print:   8.935            8.364           8.363](+0.001) Finding program targets
Timeline.Print:   8.943           8.372](+0.077) RulesAssembly.CreateTargetRules()
Timeline.Print:   9.021           8.449](+0.052) <unknown>
Timeline.Print:   9.073           8.502](+0.011) UEBuildTarget constructor
Timeline.Print:   9.084           8.513](+0.278) UEBuildTarget.PreBuildSetup()
Timeline.Print:  9.364](+44.276) UEBuildTarget.Build()
Timeline.Print:   9.364           0.000](+0.022) <unknown>
Timeline.Print:   9.387           0.022](+21.064) ExternalExecution.SetupUObjectModules()
Timeline.Print:  30.451          [21.086](+0.164) <unknown>
Timeline.Print:  30.615          [21.250](+11.225) Executing UnrealHeaderTool
Timeline.Print:  41.842          [32.477](+0.001) ExternalExecution.ResetCachedHeaderInfo()
Timeline.Print:  41.843          [32.478](+0.124) ExternalExecution.UpdateDirectoryTimestamps()
Timeline.Print:  41.983          [32.618](+11.337) UEBuildBinary.Build()
Timeline.Print:  53.321          [43.956](+0.319) <unknown>
Timeline.Print: [53.651](+0.002) Reading dependency cache
Timeline.Print: [53.654](+0.001) Reading action history
Timeline.Print: [53.656](+0.078) ActionGraph.GetActionsToExecute()
Timeline.Print:  53.656           0.000](+0.009) Prefetching include dependencies
Timeline.Print:  53.666           0.010](+0.068) Cache outdated actions
Timeline.Print: [53.734](+0.065) <unknown>
Timeline.Print: [53.800](+81.175) ActionGraph.ExecuteActions()
Timeline.Print: [134.975](+0.094) <unknown>
Timeline.Print: [135.070](+0.000) FileMetadataPrefetch.Stop()
Timeline.Print: [135.072]


I’d appreciate any help on this, as I am currently stumped and have no idea how to fix this. Thank you.

Things I’ve already tried:

  • Unticking and deleting everything to do with Android in my project settings
  • Deleting Binaries, Intermediate and Saved folders
  • Updating Xcode (unless there’s been an update in the last 2 days)

At a guess something about your blueprints are corrupted. I’d go through and recompile every blueprint and see if you can kick it into having an error, ESPECIALLY UMG blueprints. Try to compile in order of widgets that are embedded, back to standalone widgets. These are about the only things I’ve had fail like this.

Also, as a second step you should always find the build command in the log and run it in the command line yourself, as you’ll get more verbose output and often a lot more info about the error. You’ll need to navigate to where the UBT is and run it with the arguments from the log.

I can package for mac successfully so there doesn’t seem to be an issue with the blueprints, how would I go about running the build command in the command line? (Which arguments would I pass through?) Thanks for the help :slight_smile:

I’m going to suggest you do what all of us have to do at some point - make a new project and walk through the setup process from new project to packaged build (say, of the third person BP). Then go back to your game and go through each of the steps again.

If that fails, try moving your config folder, letting it make a new one, setting up the build stuff again and trying again. If that fixes it then your problem is a config setting. I had to do this recently as well.

Ugh, had to do that a couple weeks ago for android, but I guess it’s my only option now. Thanks for the help :slight_smile:

I test on my mac and found it is a UBT bug on mac,
please read this error line:
ActionThread.ActionDebugOutput: /bin/sh: /Users/Shared/EpicGames/UE_4.22/Engine/Intermediate/UnzippedFrameworks/FacebookAds/AdsUtil.embeddedframework.sh: No such file or directory you will notify that, the UE4 install on /Users/Shared/Epic Games/ path, not /Users/Shared/EpicGames, there’s a space missed!!!
to fix it you can just run the command on root account:
ln -s /Users/Shared/Epic\ Games/ /Users/Shared/EpicGames
after run this command, will create a soft link, then the build will success.

Validate your install, maybe even remove and reinstall. And verify that your permissions on your Mac are all OK. The user account you’re using should be an admin account.

This worked. Thank you so much :slight_smile:

Hey Feiwu,

I think what you have described above is the issue I’m running into when packaging for IOS from my iMac. I’m getting the same “/bin/sh: … No such file or directory”. I’m pretty new to the engine and working things out behind the scenes, could you please give me a bit more of a detailed explanation of your answer

" to fix it you can just run the command on root account:
ln -s /Users/Shared/Epic\ Games/ /Users/Shared/EpicGames

Where am I running this? in the editor with my game running, in Xcode, terminal??? am I meant to rebuild the engine in Xcode??? any help would be greatly appreciated.

Cheers
Andrew

It worked for me when I ran the command in terminal with the editor closed

Legend,

Thank you soooo much, worked a treat!

Cheers
a