Download

iOS Packaging error: iTunes not installed (but it is)

Hello, I get the following error when I’m trying to package or launch a Blueprint only project on an iOS device:

Inspecting the tutorial provided with the error message it seems that the engine thinks iTunes is not installed. I suspect the issue is the Windows Store version of iTunes which I had previously installed.
I base my assumption on this thread: iTunes installed from Windows store doesn't work - UE4 AnswerHub
Since then I have uninstalled the app version of iTunes, removed all its components from the control panel according to Apple’s guide and reinstalled the proper desktop version, but the issue remained.
Is there any known solutions or troubleshooting steps to confirm the error, I really don’t want to reinstall Windows!
Thanks!

Hello Kontur,

That error means that you must remotely connect to a Mac in order for xcode to compile things.

This requires a Mac and documentation can be found here: https://docs.unrealengine.com/en-us/Platforms/iOS/Windows

Hope that helps!

Hello Alex,

Thank you for your quick answer!

Based on this (https://docs.unrealengine.com/en-us/Platforms/iOS/QuickStart) documentation page and on my previous experiences pure Blueprint projects do not require a Mac to compile, do they?

I find the error message confusing, as clicking the ‘Tutorial’ button in the Message log after the error description brings up this window:

What is the actual error I should try and investigate?

I get the same. Only bp project - cant package or launch with same error. But, i can package a 3d person template for example. I tried to copy my content to the template project and it compiled successfully. But! One more “but”. It has the same error somethings later… No code, no custom icons, no blueprint nativization, im finally cant stand this happening to me, so i go making boring project instead of some exciting mobile games(…

The problem might be with iTunes installed through WinStore on Win10 iTunes Windows 10 App | Unreal Engine Documentation

Is there a 100% Solution? I did an iTunes cleanup (apple guide). Everything is valid, 100% Blueprint, Didn’t touch the plugins except to enable the ARKit.
So many users have this problem. I’m really frustraded now after spending a whole day of trying to fix it…

Please help :frowning:

You can’t build ARkit without mac.