iOS package fail on Mac


I am trying to package iOS on my Macbook Pro using UE 4.12.2. I have this same project successfully packaging to iOS on my Windows machine, but because now there is code added to the project, Windows can no longer package this to iOS. So I have moved the project over to my Mac and tried to package.

I have uploaded the apple developer certificate and provision which show valid. However, when I try to package, the package quickly fails with the attached log. I have been able to reproduce this in a blank blueprint project. It seems that after the project is trying to be compiled with iPhoneOS SDK 9.3, there is an error and the build fails. Can anyone give advice on what I am doing wrong or any extra settings I need to change?

link text


So the problem is only happening when the Google VR Plugin is enabled. Is this a bug or is there other settings that need to be modified when using this plugin for iOS devices?

Hello Bamwd5,

Thank you for reporting this and for narrowing it down to that plugin. After some testing, it seems as though there are some libraries missing from Binary builds which is preventing you from being able to package for iOS with that plugin enabled. There are two ways to avoid this. The most simple, obviously, is to disable the plugin. The other option is to download the source built version of the engine from Github, which will include the necessary libraries.

Either way, I’ve reported the issue itself under the bug report number UE-32126, so we’ll work on getting that library included for Binary builds.

Have a nice day!

Hey :

Thanks for the advice. I will attempt to download the Github source version. When do you think the bug will be fixed for the binary build?

Thanks for the help.

As this has a workaround, but it’s also most likely a simple fix, I can’t make any assumptions. I wouldn’t imagine it would be any later than 4.13’s Previews or full release however.

Ok, and I suppose there is not a way to add the correct library folders into the correct folder of the binary build to get it working with this version? I have never downloaded and installed the Github version

Due to the way that Binary builds are created, it wouldn’t be possible. If you need help downloading the Github build, please take a look at this guide:

There are multiple entries that should guide you through the process.

Ok great. I’ll give this a shot. Thanks!

Hey :

Are the necessary libraries for cardboard to build on iOS on all three branches of the source UE4 install? Or does only one of the versions (release, promoted, master) have the correct libraries?

Also, , I have been trying to build from source code the release 4.12.3 by following the unreal documentation link. I am having trouble finding the target UE4Editor - Mac to select my Mac. Attached is a screenshot. Please advise so that this cardboard issue can be solved for iOS.


alt text


Ok, I have been able to successfully run the 4.12.3 engine from source. After the editor opened, I opened my project for iOS cardboard that started this post. I made sure all of the settings were the same and everything was setup correctly, including the plugin for Cardboard being enabled in the plugins section of the editor. I then packaged the project successfully and installed the ipa via itunes. Everything seemed to be successful. However, when I run the app on the iphone, the splash screen shows up, but then immediately a message pops up that says “Plugin Missing - The project requires the GoogleVRHMD plugin”. It then asks if I want to disable the GoggleVRHMD plugin; If yes is selected, of course the head tracking and everything does not work and if no is selected the app closes.

Is there something that I have to do with xcode and the project specifically or with xcode and the plugin??


Hey :

I think I am getting closer. I created an xcode project from the original project from this post. I then build the project in xcode on profiling setting. After that I run the project and it opens in the source editor which I package from there for iOS and again, install the ipa in itunes. Now the app opens and does not say the plugin is missing, BUT it is not split screen, the image is scaled too large, and the head-tracking is not working. So it seems the source version of 4.12.3 still does not package the GoogleVR plugin correctly on iOS. Is this correct, or am I missing steps (like adding the GoogleVRHMD plugin in xcode or packaging the project in xcode; I don’t know how to do these if they are steps I’m missing). Please advise.

For review: From the beginning of the post, the ios package does not fail now with source version of the editor. However the GoogleVRHMD Plugin still is not packaging correctly for iOS.


Hey :

Any chance to take a look into this for anymore information? I started a new post here: 4.12.3 Source, GoogleVR Plugin work with iOS? - Plugins - Epic Developer Community Forums, since the original question has changed more to a GoogleVR Plugin question.


Hey :

Any update on this at all? Another Epic worker has stated that they are working on iOS cardboard plugin. Can you provide and further information into this or any work arounds for now?


As my colleague stated in the other post, it would be best to keep an eye on the forums and release notes as that is the first place that more information will be revealed. Unfortunately I don’t have any extra information for you.