iOS Package ERROR


I am trying to package my project for Test Flight

I’ve done all the actions of this tutorial:
But when I try package I get this:

Error Provision not found. A provision is required for deploying your app to the device.
Error Signing key not found. The app could not be digitally signed, because the signing key is not configured.

Provisioning Profiles

I have same error in 4.14.1

I’m following this question now - but have a horrible potential answer below.

I had the same issue when the iOS packaging system got its last upgrade. I rebuilt and downloaded my certificates several times, and I seem to remember deleting all my intermediate data during the process but have no idea if it helped.

But eventually it started working - and I have no idea what was wrong with the original certificates.

This also does not involve testflight so I’m not sure if that throws any caveats in, if it does I’ll be in the same bucket as you in the next couple of weeks.

Hi ,

Try un-selecting both Dev and Distro checkboxes for Certificates and Provisions, then try packaging for distribution again. Be sure to start with a clear Output Log and, if it fails, copy the entire contents of the output log, paste into a text doc and post here. This will help us better identify why your project is failing to build.



Can you send printscreen with this checkboxes?
I’m not sure where exactly I should do it

There is Loglink text

  1. First, if you haven’t tried this already, un-check these boxes and attempt to package again after clearing your Output Log:

  1. Try disabling all plug-ins.
  2. Here is a post with a solution from a user experiencing the same error:
    [4.13 tvOS problem with packaging][2] (In short, add a blank C++ element and recompile.)
  3. If all else fails, replace provisions and certificates after removing the old ones: [How to Remove Obsolete Mobile Provision Profiles (iOS)][3]
  1. I try it already, same result
  2. Should I turn off all plug-ins, without exception? (printscreen when I disabled all)
  3. I try it already, same result

Looking back over your question from the beginning, you say that you get the following error: "Error Provision not found. A provision is required for deploying your app to the device. Is this correct?

If you are trying to deploy straight to your device, there a few reasons you are getting this error:

  1. If you have any C++ code in your project, it will need to be compiled through XCode (on a Mac) before it will work on your iOS device. You can, however, launch directly on to iOS devices from a PC if your project is Blueprints only, but…
  2. If your project is Blueprints only, you will have to use your Dev Certificates and Provisions to launch directly to the device. The Dev Certificates allow you to test on your device during development but you need Distribution Certificates to actually publish/distribute your game.
  3. With your Distribution Certificates and Provisions, you package your game to a folder but at this point the game cannot be played on an iOS Device until it is uploaded to the App Store and downloaded from the App Store to the iOS device.

The difference between your development package and distribution package is that the distribution package strips down extra data that makes it playable/testable as a standalone app (thus making it smaller for distribution). While your Development certs and provisions, for security reasons, do not include permissions to distribute your game on the app store or any indication that your game is an Apple approved app.

The last image you have posted is a crash, which has nothing to do with any of this. If you would like to report the crash, please make a separate post.

As I wrote earlier I try package my project for Test Flight.

Installation on my device goes well, everything works

Just want to make sure we are on the same page… In order to upload to Test Flight you are going to have to compile your project remotely on a Mac and upload it to Test Flight using XCode or Application

Hello !

I package my project on Windows PC and upload in Application Loader from Mac lap top:)

I checked all 4 options, but the problem persists

Thanks for the additional information. Please review the following AnswerHub post which includes an explanation of why this occurring as well as a couple of workarounds: 4.13.1 iOS Provision not found despite being valid.