iOS Launch failed

Hi

I have set up Certificates and Provisioning Profiles and can Launch a default Unreal Project to iPhone. However, my own project, which will Package and play on Mac, fails with Unknown Error when launching to iPhone.

Any help would be much appreciated.

LogPlayLevel: mono: [DD]  ... Transferred 84992 KB of 95153 KB
LogPlayLevel: mono: [DD]  ... Transferred 89088 KB of 95153 KB
LogPlayLevel: mono: [DD]  ... Transferred 93184 KB of 95153 KB
LogPlayLevel: mono:  ... Finished copying to 'PublicStaging/RoseiOS.ipa' in 3.45 s
LogPlayLevel: mono: [DD] Installing IPA on device 'Eric's iPhone' ...
LogPlayLevel: mono: [DD]  ... Install is 5% complete at phase 'CreatingStagingDirectory'
LogPlayLevel: mono: [DD]  ... Install is 15% complete at phase 'ExtractingPackage'
LogPlayLevel: mono: [DD]  ... Install is 20% complete at phase 'InspectingPackage'
LogPlayLevel: mono: [DD]  ... Install is 20% complete at phase 'TakingInstallLock'
LogPlayLevel: mono: [DD]  ... Install is 30% complete at phase 'PreflightingApplication'
LogPlayLevel: mono: [DD]  ... Install is 40% complete at phase 'VerifyingApplication'
LogPlayLevel: mono: Install \ Update of "RoseiOS.ipa" failed with Unknown error 0xE800801C in 2.33 seconds
LogPlayLevel: mono: [DD]
LogPlayLevel: mono: Exiting.
LogPlayLevel: CommandUtils.Run: Run: Took 8.236637s to run mono, ExitCode=1
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:1): /Users/Shared/UnrealEngine/4.12/Engine/Binaries/DotNET/IOS/DeploymentServer.exe Install -ipa "/Users/Eric/Desktop/RoseiOS/Binaries/IOS/RoseiOS.ipa" -device 341184e5b5d1fc1f929660973187c808eef462a5 -additionalcommandline 
"-SessionId=022CD8FCF6433BE05734BEA7F5343EC3 -SessionOwner="Eric" -SessionName="Launch On Device" ". See logfile for details: 'DeploymentServer-2016.07.01-12.14.50.txt'
LogPlayLevel:   at AutomationTool.CommandUtils.RunAndLog (System.String App, System.String CommandLine, System.String Logfile, Int32 MaxSuccessCode, System.String Input, ERunOptions Options, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.CommandUtils.RunAndLog (AutomationTool.CommandEnvironment Env, System.String App, System.String CommandLine, System.String LogName, Int32 MaxSuccessCode, System.String Input, ERunOptions Options, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in <filename unknown>:0
LogPlayLevel:   at IOSPlatform.Deploy (AutomationTool.ProjectParams Params, DeploymentContext SC) [0x00000] in <filename unknown>:0
LogPlayLevel:   at Project.Deploy (AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0
LogPlayLevel:   at BuildCookRun.DoBuildCookRun (AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0
LogPlayLevel:   at BuildCookRun.ExecuteBuild () [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.BuildCommand.Execute () [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.Automation.Execute (System.Collections.Generic.List`1 CommandsToExecute, Tools.DotNETCommon.CaselessDictionary.CaselessDictionary`1 Commands) [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.Automation.Process (System.String[] CommandLine) [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.Program.MainProc (System.Object Param) [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.InternalUtils.RunSingleInstance (System.Func`2 Main, System.Object Param) [0x00000] in <filename unknown>:0
LogPlayLevel:   at AutomationTool.Program.Main () [0x00000] in <filename unknown>:0
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Domain_ProcessExit
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 122.582191
LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
PackagingResults:Error: Error Launch failed! Unknown Error

Same here, but just a different error number. I’m just a noob with UE4 in general and even more in iOS developing but as far as I’ve seen, it’s more difficult than I thought.

I’ve just arrived to this point after solving other several problems such as first trying to get certificates and provision from a dumb template iOS app from Xcode, as well as noticing the problem that unreal doesn’t like the names of the generated provision files (needed to match the bundle name), and finally founding that the signing was also failing because of the lack of information under project settings / publisher / company information (also it seems to ne necessary filled and matched with the one used in my dumb app).

At the end though it doesn’t matter very much because launching now is still becoming a nightmare for me (without having the anual fee iOS) and now the log it just says nice things like:

AMDErrorForMobileInstallationCallbackDict GOT AN ERROR 0xe8000067
        perform_command: There was an error communicating with the service agent: 0xe8000067
AMDeviceSecureUpgradeApplication : Could not upgrade package on device, error: kAMDAPIInternalError, pathToApplication: PublicStaging/MyApp.ipa
Install \ Update of "MyApp.ipa" failed with Unknown error 0xE8000067

Tomorrow I will follow and I’ll share my findings, but I needed to share this… It’s so frustrating!

were you able to get any progress in launching the project to iOS?

i have just run into this and everywhere i looked people have not figured out the solution.
i am the same, noob at unreal and iOS.

Did any of you find a way out? I am having the same issue.

Hey OLOVI
Whats the error?
may be we could find the solution together?

i did this and it worked.

also do this:
go into your project folder and delete all folders except “Config” and “Content”. Then try using the “Launch” menu in UE4 to launch to your device again. These steps will ensure that a clean build is performed.

Hi Satra18, I tried doing what u suggested but it dint help. I still have the same error!

  1. Disable all but Unreal Engine’s default plugins.
  2. Ensure that the “Bundle id” in the “app id”, packaged in your mobile provision, is literally“”[an aserisk](This is created in the apple dev portal). Do not follow apple’s example below the wildcard feild. When making a new app id set the app id type to wildcard and make the “Bundle id” literally ""[an aserisk]. Package that app id into your moblie provision and load it into your project. This allows you to put any name in the “bundle identifier” space in the Unreal project settings ->ios → bundle identifier of your project. Also you must use the “Launch” feature to launch to your device, as explained in the ios quickstart guide in unreal documentation. When I used the “project launcher” window instead, the project did not launch on my device properly.
  3. I also was not using an empty project, rather it was the third person perspective template. I tired once and it failed and then i tried again using the launch feature and it worked. Im running around the third person template on my ipad.

And Also Update ur ue4 to .18

I encountered this issue SO MANY TIMES before, this is soultion that I found to solve this issue.

Be sure your bundle identifier value in your project settings prior to trying below.

  1. Make sure whether your provision file is the latest.

  2. Go to /Users/[your account]/Library/MobileDevice/Provisioning Profiles/
    Remove all the provision files except the one valid which is the latest.

  3. In info.plist file,
    MobileProvision =
    SigningCertificate=[provision’s owner]
    Make sure If accurate provision’s owner info was input to SiginingCertificate field. and make MobileProvision field empty.

  4. Unreal → Edit → Project settings : Uncheck provision and check Certifiacte to be used in Platforms/iOS/Mobile Provision

  5. Try launching project with other device.