Ios launch fail after upgrading to 4.7.1, provision not found, signing key not found

hi, so i had a project that was using version 4.6.1 and i could launch on my ios devices just fine, then i did a convert in place on the project to upgrade it to 4.7.1 and it fails to launch and gives me this error -

i went into project settings and the mobileprovision was invalid, so i took out the prefix in the Bundle Identifier and it became valid, as seen below -

however, this did not fix the error. i even tried to go through the whole process and register the 4.7.1 version as a new app with a new mobile provision and everything, and even that didn’t work. i have been looking on the forums for days, but there is surprisingly little information about this. any help would be greatly appreciated!!! thanks!!!

I am also encountering this issue. Of Note, my output log shows :

Searching for mobile provisions that match the game ‘RemovedProjectName’ with CFBundleIdentifier=‘com.YourCompany.RemovedProjectName’ in ‘C:\Users\RemovedComputerUser\AppData\Local/Apple Computer/MobileDevice/Provisioning Profiles/’
Phase 0 considering provision ‘RemovedProjectName.mobileprovision’ named ‘RemovedProjectName’
… Failed phase 1 name check (provision app ID was

It will do that about 3 times, and then try again 3 more times and then give the errors.

The two variables that I would like to know how to set are YourCompany above and RemovedProjectName.mobileprovision. I suspect these two are what are affecting my scenario.

I set the company name in the Project Settings → Project → Description → Publisher → Company Name but I could find no where else to set it. I ran into forum posts related to setting a .plist file, but could not find any relevant plist files on my computer. In addition, I did see the notice for users from 4.6 or earlier. I therefore set the Bundle Information fields as expected. Everything is green as with tRex’s example. The Bundle Identifier follows the expected pattern of com.RemovedCompanyName.RemovedProjectName.

tRex, is this a code base project?

rodrigoreyesla, same question.

In either case (code or content), could you provide a log? That will help me narrow down what the issue could be. A lot changed in 4.7 related to finding and utilizing provisions and signing certificates. We have no way to test every possible combination of the two, so you may have just found a case which is failing. The log will help me nail down what that is.


Ok, in your case, if you go to Project Settings, IOS section and change the Bundle Identifier to com.RodrigoReyes.ipadMiniTest, does it work then?


link text

Brand new blueprint project that I created specifically to test this functionality. All I did was create a new FPS template, imported the Sci-Fi top down assets, and modified the HUD blueprint so that it would display the FPS.

Sorry Pete, I had already tried that.

attached is a screenshot of my IOS settings.

hmm… That’s not what the log is showing. It is still showing the com.YourCompany.ipadMiniTest as the bundle identifier. Can you look in Engine/Intermediate/IOS for UE4Game-Info.plist and tell me what the CFBundleIdentifier is in that file.

Actually, I know what the issue is for both of you guys. When we do a validation check before allowing File|Package we aren’t re-generating the plist file for use by the validation pass and so it reads an old out-dated file (or worse doesn’t even find one) and fails the validation. I am looking at a fix right now. If you want to get around this bug for now, go in to Engine/Intermediate/IOS and put the correct bundle identifier in the plist which resides there. If you don’t find a plist there, then check the ProjectDir/Intermediate/IOS directory for it. That should get you going until I can get this fix.



this : Engine/Intermediate/IOS/UE4Game-Info.plist is exactly the information that I needed. In there the CFBundleIdentifier was set exactly to com.YourCompany.ipadMiniTest. Modified it as expected, and Viola! we have expected functionality.

Thank you very much, I now have a successful deploy to an ipadMini2 :slight_smile:

thanks for the help!!! pretty sure this was my issue as well, but last night i opened the project launcher and launched from there and it somehow fixed the problem.

Glad yours is working. There will be a fix for this problem in the next point release which should be coming by the end of the week.