Download

iOS Launch Error

Hi

I am using Unreal Version 4.12.3 on an iMac. I am having difficulty Launching projects on iPhone and iPad.

For all projects I try, including the basic FirstPersonExampleMap I get;


Invalidating cooked content because Engine:Core.System:Paths:../../../Engine/Content ini setting was out of date

I have tried the same thing in an older version of Unreal 4.10.4 and it works although I do get Warnings


 LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_190b_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_383b_0///####STATCAT_Advanced####

As I am fairly new to this I expect I am doing something wrong but any help would be much appreciated.

Here is the end of the Logfile when using 4.12.3:


 LogChunkManifestGenerator:Display: Done saving asset registry.
 LogCook:Display: Cook by the book total time in tick 22.282954s total time 34.388348
 LogPlayLevel: Completed Launch On Stage: Cooking in the editor, Time: 23.989284
 LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_19e2f_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_109ef_0///####STATCAT_Advanced####
 LogPlayLevel: Running AutomationTool...
 LogPlayLevel: Setting up Mono
 LogPlayLevel: Start UAT: mono AutomationTool.exe -ScriptsForProject=/Users/Eric/Documents/Unreal Projects/MyProject4/MyProject4.uproject BuildCookRun -project=/Users/Eric/Documents/Unreal Projects/MyProject4/MyProject4.uproject -noP4 -clientconfig=Development -serverconfig=Development -nocompile -nocompileeditor -installed -ue4exe=UE4Editor -utf8output -plat
 form=IOS -build -map=/Game/FirstPersonBP/Maps/FirstPersonExampleMap -skipcook -iterativecooking -compressed -iterativedeploy -stage -deploy -cmdline=/Game/FirstPersonBP/Maps/FirstPersonExampleMap -Messaging -device=IOS@341184e5b5d1fc1f929660973187c808eef462a5 -addcmdline=-SessionId=A3AA4A434D4DFDECAC76E0A761AEB132 -SessionOwner='Eric' -SessionName='Launch On
  Device'  -run
 LogPlayLevel: Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=/Users/Eric/Documents/Unreal Projects/MyProject4/MyProject4.uproject BuildCookRun -project=/Users/Eric/Documents/Unreal Projects/MyProject4/MyProject4.uproject -noP4 -clientconfig=Development -serverconfig=Development -nocompile -nocompileeditor -installed -ue4exe=UE4Editor -
 utf8output -platform=IOS -build -map=/Game/FirstPersonBP/Maps/FirstPersonExampleMap -skipcook -iterativecooking -compressed -iterativedeploy -stage -deploy -cmdline=/Game/FirstPersonBP/Maps/FirstPersonExampleMap -Messaging -device=IOS@341184e5b5d1fc1f929660973187c808eef462a5 -addcmdline=-SessionId=A3AA4A434D4DFDECAC76E0A761AEB132 -SessionOwner='Eric' -Sessio
 nName='Launch On Device'  -run
 LogPlayLevel: Automation.Process: Setting up command environment.
 LogPlayLevel: BuildCookRun.SetupParams: Setting up ProjectParams for /Users/Eric/Documents/Unreal Projects/MyProject4/MyProject4.uproject
 LogPlayLevel: Project.Build: ********** BUILD COMMAND STARTED **********
 LogPlayLevel: Completed Launch On Stage: Build Task, Time: 2.022824
 LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_1bbc7_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_109ef_0///####STATCAT_Advanced####
 LogPlayLevel: CommandUtils.Run: Run: mono "/Users/Shared/UnrealEngine/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe" UE4Game IOS Development   -remoteini="/Users/Eric/Documents/Unreal Projects/MyProject4" -noxge -generatemanifest -nocreatestub -NoHotReloadFromIDE
 LogPlayLevel: mono: Compiling with iPhoneOS SDK 9.3
 LogPlayLevel: mono: ERROR: No modules found to build. All requested binaries were already part of the installed engine data.
 LogPlayLevel: CommandUtils.Run: Run: Took 1.979438s to run mono, ExitCode=5
 LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:5): /Users/Shared/UnrealEngine/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe UE4Game IOS Development   -remoteini="/Users/Eric/Documents/Unreal Projects/MyProject4" -noxge -generatemanifest -nocreatestub -NoHotReloadFromID
 E. See logfile for details: 'UnrealBuildTool-2016.06.25-19.14.39.txt'
 LogPlayLevel:   at AutomationTool.CommandUtils.RunAndLog (System.String App, System.String CommandLine, System.String Logfile, Int32 MaxSuccessCode, System.String Input, ERunOptions Options, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in <filename unknown>:0
 LogPlayLevel:   at AutomationTool.CommandUtils.RunAndLog (AutomationTool.CommandEnvironment Env, System.String App, System.String CommandLine, System.String LogName, Int32 MaxSuccessCode, System.String Input, ERunOptions Options, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in <filename unknown>:0
 LogPlayLevel:   at AutomationTool.CommandUtils.RunUBT (AutomationTool.CommandEnvironment Env, System.String UBTExecutable, System.String CommandLine, System.String LogName, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.CommandUtils.RunUBT (AutomationTool.CommandEnvironment Env, System.String UBTExecutable, UnrealBuildTool.FileReference Project, System.String Target, System.String Platform, System.String Config, System.String AdditionalArgs, System.String LogName, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in <filename unkno
 wn>:0
 LogPlayLevel:   at AutomationTool.UE4Build.BuildWithUBT (System.String TargetName, UnrealTargetPlatform TargetPlatform, System.String Config, UnrealBuildTool.FileReference UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, System.String InAddArgs, Boolean ForceUnity, System.Collect
 ions.Generic.Dictionary`2 EnvVars) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.UE4Build.Build (AutomationTool.BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, System.Collections.Generic.Dictionary`2 PlatformEnvVars, Nullable`1 InChangelistNumberO
 verride, System.Collections.Generic.Dictionary`2 InTargetToManifest) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at Project.Build (AutomationTool.BuildCommand Command, AutomationTool.ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at BuildCookRun.DoBuildCookRun (AutomationTool.ProjectParams Params) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at BuildCookRun.ExecuteBuild () [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.BuildCommand.Execute () [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.Automation.Execute (System.Collections.Generic.List`1 CommandsToExecute, Tools.DotNETCommon.CaselessDictionary.CaselessDictionary`1 Commands) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.Automation.Process (System.String] CommandLine) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.Program.MainProc (System.Object Param) [0x00000] in &lt;filename unknown&gt;:0
 LogPlayLevel:   at AutomationTool.InternalUtils.RunSingleInstance (System.Func`2 Main, System.Object Param) [0x00000] in <filename unknown>:0
 LogPlayLevel:   at AutomationTool.Program.Main () [0x00000] in <filename unknown>:0
 LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=5 (5)
 LogPlayLevel: Domain_ProcessExit
 LogPlayLevel: Completed Launch On Stage: Build Task, Time: 1.512805
 LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
 PackagingResults:Error: Error Launch failed! Unknown Error