Download

iOS Inputs not working on deployed Build

Hi guys, unsure if this is the right section for this issue but didn’t know where else to put it…

Having an in issue with my packaged build on iOS.
Finally got my app onto the iPhone via test flight, and thought I was onto a winner with it. But none of my inputs work. I am using the “get motion state” node on an event tick to deck if the phone has been shook, and a few UMG Widget button, none of which are working on the deployed build. However, when I run it via the uRemote 2 app, it works perfectly, ignoring the lag in the network.

I have this working on an android build, so I know that my blueprints do work, it just seems to not like it on iOS.

I have went through and tried multiple combinations of the input settings as well as just enabling all apple plugins, but I am running at a brick wall at the moment.

Anything I have come across on the forums etc I have tried, but to no luck. Enable mouse as input, making widgets focusable, etc

Is there something incredibly obvious I am missing when it comes to iOS ?

The App was originally built as blueprint only, but has been migrated into a xcode project. UE 4.27, Xcode 12.4, iphone x on iOS 14.8.

If anyone has any ideas that would be greatly appeciated, I am running out of sanity

Thanks