IOS Icon (Wont change from unreal engine icon)

Hi, i’m trying to change the icon for my ios application but i keep getting the default unreal engine logo as the icon.

I have manually changed all the pictures within Document/UnrealProject/“Project”/Build/Ios/Resources/Graphics and have also imported all the pictures within the editor in ProjectSettings–>IOS but still nothing. All the icons displayed within project settings are displayed as my own personalised ones.

I’ve found a solution to the problem but its quite long. Contact me if you need help on the subject.

Hello, how did you change it in the end, thank you

Hi , you need to remote build your project using a mac if you are using a pc workflow. Send me your discord or skype if you like and ill be able to help you much faster.

I already changed all the ios icons but they still appear even when I remote build I am using Version 4.22.2 how did you manage to do it?

I honestly don’t remember anymore. If you have discord pm me your username and i’ll try give you a call when i’m free.

Hi - did you manage to find a solution for this? We are having the same challenge. Any insights would be hugely appreciated.

I was stuck on this problem for months but as i said it was a long time ago and i don’t really remember how i found the solution. If u can discord you can tell me the steps you are taking to re jog my memory and see if i can be of any help :slight_smile:

That is very kind, thankyou.
Here is a summary so far on Windows.

  • A blueprint only project - with all plugins and ios icons default + the correct install of itunes + valid provisioning profiles. Launching and building a projects works perfectly.
  • Updating any of the icons in prefs (which is the same as creating in them in…/Build/Ios/Resources/Graphics folder) promps a remote build or the “itunes is not installed” and fails.
  • Also disabling any plugins (which updates the .uproject file) fails the build.
  • As a dirty hack, I have tried modifiying all the ios icons in the engine folder at the following locations
  • Engine\Binaries\IOS\Payload\
  • Engine\Build\IOS\Resources\Graphics
  • Engine\Build\IOS\Resources\Assets.xcassets\AppIcon.appiconset
  • The app builds/ launches, but miraculously with the default UE logo as the icon on the ipad

This is as far as I have persued just on windows. I do have a mac available in our office for remote builds, which I suspect will be needed? But this is not something I have tried to configure yet.

Thanks again for your time + offer, and I will drop you a discord when I have the mac ready.

Changing the images in the folders have no effect for some reason. At one point i deleted every unreal logo image i had on my pc but ue4 still managed to find it so how!

You will need a mac (with x-code) for a structured (remote) build and this will most likely sort out the icon issue as it has done with most people but did not work for me.