IOS DLLs in my Win64 build: Is it necessary?

Hello there.

Currently, my UE4 engine is a hybrid from various 4.10 forks because they offer additional third party support. One of them might have triggered some compiling flag that enables the build of various IOS DLLs in \Engine\Binaries\Win64\IOS. One of those DLLs is actually causing me (not fatal but annoying) trouble with messages such as this:


There could be a genuine bug to address but with the hybrid nature of my engine, I won’t try to address it here unless I do thorough analysis of every clone I’m using. But I don’t really care for TVOS or IOS for that matter. Is there a way to remove it completely from my build ?


It seems like you’re missing the TVOSTargetPlatform.dll. You might need to rebuild your version of the engine or verify which part of the clone caused it. I’m going to also attach this file and see if you adding it into that folder will fix the issue.



Thanks Samantha. It landed on a Google Drive directory to which permission was required. Signed in as @marcthenarc. Thanks.


It looks like they’ve changed the permissions recently. Here is another link that should work properly for you: DropBox

Let me know if it causes more trouble, thanks!

Thanks. It worked. However, the problem was not that is was missing, but it didn’t find a specific function in it. I replaced it with yours and it worked. I wonder why this happened. Does “Setup.bat” pull this file in or is it built with the UE4.sln solution ? In any case, I’ll keep that file handy whenever I need to fetch / build a new engine.

I believe that when the build was being built in VS it either had a malfunction or missed some files. Let me know if you run into any other wonky issues though. :slight_smile: