Download

iOS distribution build provisioning problems

Hiya. I’m having a dickens of a time getting my iOS project to do a distribution build. I’m attempting to get a build ready to distribute for TestFlight, so let me know if I’ve chosen the wrong kind of provision or anything.

So currently I have my certificate loaded and a mobile provision. The provision says there’s no valid certificate found. I’ve followed the Quick Start guide to the letter except where I deviate into an Ad-Hoc provision using a Distribution profile. That didn’t work, although the process worked fine for development.

So I’ve modified the process down to the following steps:

  1. Wipe out all previous certificates and provisioning profiles, including under ~/Library/MobileDevices/Provisioning Profiles, so they’re gone from UE as well.
  2. Open XCode and create a new Distribution profile.
  3. Load up Apple Developer site and verify Distribution profile now exists on the site.
  4. Load UE and set the Bundle ID. Check “Distribution build”.
  5. Create provisioning profile using previously created AppID and the certificate.
  6. Download provisioning profile and import it to UE.
  7. Open keychain and find certificate and modify it to “Always Trust” so that it’s active immediately.
  8. Download certificate and import it to UE.
  9. Provisioning profile still says “No valid certificate found”.

I’ve also tried exporting the certificate from the keychain and reimporting it into UE. No luck there either.

Just tried doing a full AppStore distribution provision, no difference.

Tried making a new AppID with a new bundle identifier too, then a new provision. No luck there either.

Is there a step I’ve missed? I’m definitely using the right certificate to create the provision.

Ever since 4.13 came out, we’ve all struggled with provisioning for iOS devices. I’m currently building 4.15.1-release from source since hacking 4.13 was the only way I could get it to accept the valid provisioning profile and certificate that I have. Our team has released several apps to the App Store (4.12 and older) without issue. Something changed significantly in 4.13+ that has wreaked havoc with little relief in sight.

What I know it was change in new Xcode not in UE4. But for now everything works good for me (with default configs)… UE 4.15 + Xcode 8.2.1