iOS Control screensaver no longer works in 4.9

Disabling the screensaver using Control Screensaver node in blueprint no longer works, tried on Iphone6,Iphone4s, all with latest update patch from itunes.
I have tried running the function in event BeginGame and also in event tick help please!

I have same issue with iPod touch5.

Hello d0nt4g3t,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you provide more information on what exactly happens and how it is inverse to what it is you would expect?

Hello d0nt4g3t,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

yes the same thing happens with a clean project
just a empty project with an actor and i simply run the control screensaver node in beginplay without the tick to disable screensaver
I want my app to always be running so that the screen does not dim if the user does not touch the screen after some time, but after i build on ios devices, the screen will always dim first, then the phone will goto lock screen

Hello d0nt4g3t,

I was able to reproduce this issue on our end. I have written up a report ( UE-21875) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Is their anything happen on this Problem? Or does someone knows a Workaround (especally for IOS) because I have the Problem now to.
I’ve tried to use IOSAppDelegate class in C++ directly → Same Result, my App goes in Sleep-Mode
Also tried to use call the Delegate directly but even when my debug var tells me, that the idleTimerDisables == true the screen shuts down.

Please Help! :wink: