Download

iOS build - failing to ping mac

Hello,

I’m working for my first time with UE4 and Mac/iOS and are currently trying to build my project following this guide. However I always get this error:


MainFrameActions: Packaging (iOS): UnrealBuildTool: Picking the default remote server 
MainFrameActions: Packaging (iOS): UnrealBuildTool: Remote compiling requires a server name. Use the editor to set up your remote compilation settings.
MainFrameActions: Packaging (iOS): UnrealBuildTool: Failed to ping 
MainFrameActions: Packaging (iOS): UnrealBuildTool: Exception details: System.ArgumentNullException: Der Wert darf nicht NULL sein.
MainFrameActions: Packaging (iOS): UnrealBuildTool: Parametername: hostNameOrAddress
MainFrameActions: Packaging (iOS): UnrealBuildTool:    bei System.Net.NetworkInformation.Ping.Send(String hostNameOrAddress, Int32 timeout, Byte] buffer, PingOptions options)
MainFrameActions: Packaging (iOS): UnrealBuildTool:    bei System.Net.NetworkInformation.Ping.Send(String hostNameOrAddress)
MainFrameActions: Packaging (iOS): UnrealBuildTool:    bei RPCUtility.CommandHelper.PingRemoteHost(String RemoteHostNameOrAddressToPing) in c:\UE4\Engine\Source\Programs\RPCUtility\Program.cs:Zeile 40.
MainFrameActions: Packaging (iOS): UnrealBuildTool: Failed to ping Mac named

Yep, Im stupid (apparently). Additionaly, the BuildConfiguration.xml magically resets after every packaging try.
Any hints on how to point to my MAC correctly? Thanks

Freienstein

EDIT: setting the mac IP in RemoteToolChain.cs and rebuilding the tool solves this problem

You don’t need to hardcode the IP in the source. Go to the UE4 “Engine/Saved” folder, create a folder called “UnrealBuildTool” and paste the text below in a file called “BuildConfiguration.xml”:


<?xml version="1.0" encoding="utf-8" ?><Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">
	<RemoteToolChain>
		<RemoteServerName>YOUR MAC IP ADDRESS OR HOST NAME HERE</RemoteServerName>
	</RemoteToolChain>
	<BuildConfiguration>
	</BuildConfiguration>
</Configuration>


Put your Mac’s IP or host name in the specified XML tag and you’re golden.

Nah, that would be too easy.

Thanks for the help